ReadyBoost is disabled by system due high disk performance

chuckov

Honorable
Oct 7, 2012
1
0
10,510
0
I am running windows 7.1. On the non boot SSD and the USB flash drive properties/ReadyBoost I get "Readyboost is not
enabled on this machine because the system's disk performance is high....."
The USB HHD is 2.0, and the internal HHD is SATA II.
It seems to me the two HHDs could really benefit from this caching...
I would like to use the non boot SSD (D:) as the location for the cache.
Discussion and/or solution would both be helpful --- has anybody run benchmarks on this type of configuration?
Thank you in advance for your help
 

getochkn

Polypheme
Moderator
SSD is faster than the USB stick, and thus would slow down having to cache across the USB bus. SATA 2 is still way faster than USB. 300MB/s for Sata, 35MB/s for USB. Almost 10x faster. Using the USB stick would slow caching down by an order of 10, thus Windows disables it.
 

elel

Distinguished
Jun 18, 2009
1,042
0
19,360
29
Yes, that's true. I tried to install readyboost on my SSD powered laptop to move the writes to a cheap drive. As you found out, windows disables readyboost if your hard drive score is over a certain threshold. I was unable to find a way to re-enable it. As getochkn said, a USB2 flash drive is going to be so much slower than an SSD that there's no comparison. Check out this superuser thread for instructions on how to move your paging file to a different drive. Also if you have money to spend on boosting your laptop's performance I would go for RAM. An SSD was a very good first move, but remember that Windows uses free RAM to build a cache of recently used files. And RAM is faster than anything but processor cache.
 

ASK THE COMMUNITY

TRENDING THREADS