Question Really Need Help On RGB Fans Lights Not Working. Almost a month with this problem!

Apr 3, 2019
3
0
10
0
So, I've posted this on a handful of forums but I haven't got replies. I really need help on this and there is no information with the same problem I'm having. Any help would be much much much appreciated!

Here's the problem: My LEDdess RGB fans spin but the RGB on the fans and LED strips does not work. There are faint green and blue LEDs on but I can't control the RGB so its stuck on that setting. I get no response when trying to use the remote. The remote itself works because the red light on it turns on when using it but does not change the fan/LED strip lights at all when pressing buttons. This same exact problem happened to me on the last set of RGB fans I tried (completely different brand, upHere RGB fans). The fans and LED strips are powered through a hub which is connected to molex. I have tried various things with the power supply. I have tried plugging the molex into all other molex ports on the cord. The PSU is fully modular, so I tried plugging in the molex cord to different compatible ports on the PSU (EVGA Supernova 850 G2) but that did not work. I tried using a different molex cord no luck. Everything else on the PC works great and is powered just fine. I knew the SATA cord worked because it is powering my case LEDs so I tried using a SATA to molex adapter that did not work.

It has me puzzled because everything else works great on the power supply. So, I am so slumped on this. Especially with the lack of replies. Please help!! 😭
 
Apr 3, 2019
3
0
10
0
Anyone think I just need a new power supply? I hate to have wasted money on this Supernova 850 G2 but if its broken then its broken.
 

ASK THE COMMUNITY

TRENDING THREADS