[SOLVED] Really really strange bug with a Samsung G7 Odyssey (video included)

Yeldur

Reputable
Jan 28, 2017
175
21
4,695
4
Hi there,

I've got a very very odd bug that I've found today, essentially when I access Prime Video or Netflix, the entire monitor will go into a blackscreen state -> power off the entire display including LEDs-> power on -> switch the display to my other monitor -> switch back to the other monitor -> turn the display back on

Sometimes it will also do this (This is the most prevalent): entire monitor goes into blackscreen state -> powers off the entire display including LEDs -> powers back on -> remains on a black screen until I physically turn off the power to the monitor and plug it back in again

Does anybody have any idea on what the hell is doing this? So far it has only happened when accessing Prime Video or Netflix. Disney+ works fine and so does YouTube! Once the page loads it seems to work OK, but as soon as I do anything that causes something to change on the page such as start a video, or navigate somewhere, the entire thing happens again.

YouTube Video Here!

It's quite literally rendered Prime Video and Netflix completely unusable! Can anyone help?
 

Yeldur

Reputable
Jan 28, 2017
175
21
4,695
4
I've worked out the issue!

I believe it's down to a faulty DP Port on my GPU, strangely enough, the new monitor works completely fine on that port, it's ONLY when accessing prime video and netflix that it freaks out, plays games, runs youtube completely fine and without problem.

I plugged my secondary monitor into that port and nothing, nada, won't even recognise that it's plugged into a displayport.

I switched both the connections round and didn't use that DisplayPort and voila, everything is working again.


I have absolutely no idea why that specific port caused issues specifically with Netflix and Prime Video as a website, this is by far the strangest issue I've ever seen.
 

Yeldur

Reputable
Jan 28, 2017
175
21
4,695
4
I've worked out the issue!

I believe it's down to a faulty DP Port on my GPU, strangely enough, the new monitor works completely fine on that port, it's ONLY when accessing prime video and netflix that it freaks out, plays games, runs youtube completely fine and without problem.

I plugged my secondary monitor into that port and nothing, nada, won't even recognise that it's plugged into a displayport.

I switched both the connections round and didn't use that DisplayPort and voila, everything is working again.


I have absolutely no idea why that specific port caused issues specifically with Netflix and Prime Video as a website, this is by far the strangest issue I've ever seen.
 

ASK THE COMMUNITY

TRENDING THREADS