Question Realtek audio drivers missing/no audio onput device installed

May 1, 2019
1
0
10
0
Specs:
CPU: MSI GP73 Leopard 8RE i7-8750H
RAM: 16gb
SSD/HDD: 500gb/1tb
GPU: NVIDIA GTX 1060
OS: Windows 10

Good evening.I have been troubleshooting my audio for 2 days now. Yesterday when I got home and turned my laptop on i noticed my speaker icon in bottom right had a "red x" Highlighting over it displays "no audio output device is installed".
I immediately went to device manager and noticed 2 things: my realtek drivers were ALL missing from sound controller and High Definition Audio Controller was located under System Devices and not Sound Controller and has an inverted yellow triangle icon on it with error code 10.

I removed drivers for the High Definition Audio Controller then searched for hardware configuration changes. These drivers popped back up under System Devices. I tried to remove the drivers and do a reboot. They appear back under System Devices still.
I tried to download Realtek drivers directly from the MSI website. The install Shield goes through its process and restarts my computer but the drivers never show up under device manager.
Ive verified all my windows updates are current.

Ive gone into apps and features and manually removed the realtek drivers then tried to reinstall them again from the MSI download. They still dont show up under device manager.

Apart from a complete system wipe im not sure what to do anymore. Any help will be greatly appreciated!
 

viveknayyar007

Splendid
Moderator
Hello

Can you please try the solutions given here and see if any of these helps? Although you might have already tried some of them in the link, the new ones can do the trick.

You may also want to get to the Services.msc snap-in, and try stopping and re-starting the Windows Audio service.

Hope this helps.

Cheers!!
 

onespeedbiker

Prominent
Apr 13, 2019
948
49
490
18
One possibility is your Realtec drivers have become corrupted and need to be uninstalled from your computer before they can be reinstalled. First check to see if they are loaded as a program, Control Panel > Programs and Features and see in your Realtec drivers are listed, if they are uninstall them. Next go to C:\ and see if there is a Realtec folder. If so delete it. Then go to C:\Programs and again see if there is a another Realtec folder; if so delete the contents also. Now check and see if the Realtec driver install file is in your Download Folder so you can access it later. Now reboot for computer and reinstall the Realtec drivers..
 

ASK THE COMMUNITY