[SOLVED] Realtek Digital Output (Optical) Not Showing

Isotope5667

Distinguished
Jul 6, 2012
55
0
18,530
0
I am attempting to connect my Astro A40's using an optical cable, and I am supposedly supposed to set Realtek Digital Output (optical) as the primary device in sound control panel; however, this option is completely absent. The attached picture is my current Sound Control Panel:



I've tried to reinstall the Realtek drivers and even did a fresh install of Windows 10 at one point, but nothing has made this option pop up. I'm willing to try or retry any solutions!

I've troubleshooted this a lot and am at a complete loss. I have a Asus z170 Pro Gaming mobo if that helps.

Thanks :)
 
Why do you think digital output and digital output(optical) is a different thing?
If your Realtek audio device has only single digital/optical output, then it doesn't matter, if it's called digital or digital(optical). It's the same thing.
 

Isotope5667

Distinguished
Jul 6, 2012
55
0
18,530
0
Have you tried the steps in this tutorial?
Yes, I've seen this thread. The main issue is that the option that they select - Realtek Digital Output (Optical) - just doesn't show up in my sound control panel. You can see the difference between their image and mine.

Theirs:



Mine:
 

Isotope5667

Distinguished
Jul 6, 2012
55
0
18,530
0
Is Realtek Optical listed in your Realtek HD Audio Manager?
Is Realtek Optical listed under "Device Manager > Sound, video and game controllers"?

Realtek optical is not listed in my Realtek HD Audio Manager, but it does show that the optical port on my motherboard is being used.



Realtek audio does not show up in my audio manager either, but it doesn't show the non-optical option either... Only the Realtek HD Audio Manger.

 

Isotope5667

Distinguished
Jul 6, 2012
55
0
18,530
0
Have you gone to "PC Settings > System > Sound > Troubleshoot/Manage Sound Devices"?
Just checked that out - when entering into the troubleshooting menu there is not option for me to 'troubleshoot' the optical option because its not there. There must be something where my computer just completely does not recognize this option at all.
 
Why do you think digital output and digital output(optical) is a different thing?
If your Realtek audio device has only single digital/optical output, then it doesn't matter, if it's called digital or digital(optical). It's the same thing.
 

Isotope5667

Distinguished
Jul 6, 2012
55
0
18,530
0
Why do you think digital output and digital output(optical) is a different thing?
If your Realtek audio device has only single digital/optical output, then it doesn't matter, if it's called digital or digital(optical). It's the same thing.
Wow.. I feel extremely silly now. Upon looking more into it and looking at the properties I think you're totally right. I just assumed I was missing an option since setup guides (like the one that was linked in the first reply to this thread) included this explicit option and mine never appeared. Looking at this properties tab, it seems like this is the option that uses my rear optical output jack, correct?


If this is the case, thank you for the clarification.
 

Isotope5667

Distinguished
Jul 6, 2012
55
0
18,530
0
Why do you think digital output and digital output(optical) is a different thing?
If your Realtek audio device has only single digital/optical output, then it doesn't matter, if it's called digital or digital(optical). It's the same thing.
Yup. I messed around with some of my connections and my default devices and my headset works perfectly. I feel incredibly stupid, especially considering I reset Windows 10 for this previously.

Thanks so much again.
 

ASK THE COMMUNITY

TRENDING THREADS