Question Realtek HD Audio Device is not showing up in Device Manager ?

Jul 23, 2022
12
0
10
0
Realtek HD Audio Device is not showing up in Device Manager and in drivers update utilities (Driver Booster, Driver Easy). In Device Manager showing up only AMD HD Audio Device. I tried almost evrything. Uninstall and Install realtek drivers from Motherboard's website and Realtek's website, Set default BIOS settings and More. I realy cant found the solutions and need yours help. For a long time I also had a uninstalled front panel Audio (maybe this could be the reason)...

PC specs:
Windows 10
AMD RX 580
Rysen 3 1200
Asrock b450 pro4
Realtek ALC982
 

Ralston18

Titan
Moderator
ln Device Manager > View double check that "Show hidden devices" is checked.

Refer to the respective motherboard and case User Guides/Manuals to reconnect the front panel audio. Verify that the connection(s) are correct.

Run the built-in Windows troubleshooters. The troubleshooters may find and fix something.

Not sure about the process you used to reinstall the drivers.

Do not use any third party driver installers or tools.

Manually download the applicable sound card drivers via the manufacturer's website.

Reinstall and reconfigure.
 
Jul 23, 2022
12
0
10
0
ln Device Manager > View double check that "Show hidden devices" is checked.

Refer to the respective motherboard and case User Guides/Manuals to reconnect the front panel audio. Verify that the connection(s) are correct.

Run the built-in Windows troubleshooters. The troubleshooters may find and fix something.

Not sure about the process you used to reinstall the drivers.

Do not use any third party driver installers or tools.

Manually download the applicable sound card drivers via the manufacturer's website.

Reinstall and reconfigure.
Hidden devices is checked

Front Panel HDAUDIO connected

Driver is installed, but sound card still not showing up

Manually download drivers Doesnt help, tried for a few times
 

Ralston18

Titan
Moderator
What about the Windows Troubleshooters?

Other things you can do:

Look in Reliability History and Event Viewer for any audio related error codes, warnings, or informational events. May or may not be obvious.

Try running "sfc /scannow" and "dism"

References:

https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161

https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image
but if sound card is missing from device manager, isnt that bios related?
unless soundcard kicked bucket
 
Jul 23, 2022
12
0
10
0
What about the Windows Troubleshooters?

Other things you can do:

Look in Reliability History and Event Viewer for any audio related error codes, warnings, or informational events. May or may not be obvious.

Try running "sfc /scannow" and "dism"

References:

https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161

https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image
Cant start Windows Audio Trobleshooters because doesnt have my headphones in device list... (only HDMI Digital Audio)
 

Ralston18

Titan
Moderator
@timcom228

Are you able to right click the small speaker icon usually found in the lower right screen corner.

If so, doing so should open a five item menu with each listed item leading to various windows, tabs, and property settings.

There are many so just work through them to double check the information and configuration options that are presented. Do not immediately change anything and remember that "Cancel" is your friend. Make note of anything that is unexpected or not as expected. Post accordingly.

= = = =

Another tool: Powershell.

Try the Get-CimInstance win32_sounddevice | fl cmdlet.

From my computer (bold text):

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

Try the new cross-platform PowerShell https://aka.ms/pscore6

PS C:\Users\XXXX> Get-CimInstance win32_sounddevice | fl


Manufacturer : Realtek
Name : Realtek Audio
Status : OK
StatusInfo : 3

Manufacturer : Intel(R) Corporation
Name : Intel(R) Display Audio
Status : OK
StatusInfo : 3

Manufacturer : Logitech
Name : Pro 9000
Status : OK
StatusInfo : 3

Manufacturer : NVIDIA
Name : NVIDIA High Definition Audio
Status : OK
StatusInfo : 3


Objective to determine what the system is "seeing" with respect to sounddevices.

You can open Powershell (as admin) , copy the " Get-CimInstance win32_sounddevice | fl" cmdlet" (without quotes) and then paste the cmdlet at your PS> prompt.

Once run, simply copy the results and post here.

Per @kerberos_20 could be that the sound card has kicked the bucket.
 
Jul 23, 2022
12
0
10
0
Manufacturer : (USB Audio Device)
Name :USB Audio Device
Status : OK
StatusInfo : 3

Manufacturer : Microsoft
Name : High Definition Audio Device
Status : OK
StatusInfo : 3


USB Audi Device its my USB Micro
 
Jul 23, 2022
12
0
10
0
@timcom228

Are you able to right click the small speaker icon usually found in the lower right screen corner.

If so, doing so should open a five item menu with each listed item leading to various windows, tabs, and property settings.

There are many so just work through them to double check the information and configuration options that are presented. Do not immediately change anything and remember that "Cancel" is your friend. Make note of anything that is unexpected or not as expected. Post accordingly.

= = = =

Another tool: Powershell.

Try the Get-CimInstance win32_sounddevice | fl cmdlet.

From my computer (bold text):

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

Try the new cross-platform PowerShell https://aka.ms/pscore6

PS C:\Users\XXXX> Get-CimInstance win32_sounddevice | fl


Manufacturer : Realtek
Name : Realtek Audio
Status : OK
StatusInfo : 3

Manufacturer : Intel(R) Corporation
Name : Intel(R) Display Audio
Status : OK
StatusInfo : 3

Manufacturer : Logitech
Name : Pro 9000
Status : OK
StatusInfo : 3

Manufacturer : NVIDIA
Name : NVIDIA High Definition Audio
Status : OK
StatusInfo : 3


Objective to determine what the system is "seeing" with respect to sounddevices.

You can open Powershell (as admin) , copy the " Get-CimInstance win32_sounddevice | fl" cmdlet" (without quotes) and then paste the cmdlet at your PS> prompt.

Once run, simply copy the results and post here.

Per @kerberos_20 could be that the sound card has kicked the bucket.
thats it
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
58,129
4,718
161,190
10,348
Manufacturer : Microsoft
Name : High Definition Audio Device
Status : OK
StatusInfo : 3
this is probably your sound card. Microsoft installs its own drivers on realtek cards. They are actually older realtek drivers.

Driver Booster, Driver Easy
you shouldn't use programs like these, they can make things worse by installing wrong drivers.

what you might have to do is uninstall the sound drivers ON the HD Audio decvice and then run the realtek installer (by coincidence I did this very thing less than 2 hours ago). If it did recognise the realtek drivers now, good chance you get stuck in a loop as installer has 2 steps.
  1. uninstall old drivers and restart
  2. install new drivers.
If anything like me, the installer get stuck repeating step 1. I stopped it doing that after restarting 2 times, I then looked for answers.
)
 
Jul 23, 2022
12
0
10
0
this is probably your sound card. Microsoft installs its own drivers on realtek cards. They are actually older realtek drivers.


you shouldn't use programs like these, they can make things worse by installing wrong drivers.

what you might have to do is uninstall the sound drivers ON the HD Audio decvice and then run the realtek installer (by coincidence I did this very thing less than 2 hours ago). If it did recognise the realtek drivers now, good chance you get stuck in a loop as installer has 2 steps.
  1. uninstall old drivers and restart
  2. install new drivers.
If anything like me, the installer get stuck repeating step 1. I stopped it doing that after restarting 2 times, I then looked for answers.)
I think Thats AMD HD Audio, because i uninstal AMD HD Audio Driver for test 1 day ago.
 
Jul 23, 2022
12
0
10
0
this is probably your sound card. Microsoft installs its own drivers on realtek cards. They are actually older realtek drivers.


you shouldn't use programs like these, they can make things worse by installing wrong drivers.

what you might have to do is uninstall the sound drivers ON the HD Audio decvice and then run the realtek installer (by coincidence I did this very thing less than 2 hours ago). If it did recognise the realtek drivers now, good chance you get stuck in a loop as installer has 2 steps.
  1. uninstall old drivers and restart
  2. install new drivers.
If anything like me, the installer get stuck repeating step 1. I stopped it doing that after restarting 2 times, I then looked for answers.
)
INstaling Realtek drivers gives me nothing
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
58,129
4,718
161,190
10,348
ah ok.

BIOS UEFI B450M Pro4 p5.30
thats a bios not even ment for you CPU, bios P3.50 was last compatible with your CPU, having wrong bios version can have compatibility issues
Update BIOS its a last thing i will do, because that not so easy thing to do.
its not an update, its a rollback.
BIOS 3.60 removed support for your CPU and replaced it on the BIOS chip with support for Matisse CPU which are the 3000 series.
BIOS 4.50 added support for 5000 series, possibly removing more support for previously supported CPU. It isn't mentioned.
So its possible one of those updates rewired how the sound works...

Asrock only Motherboard maker it seems, that removes support for older CPU when they add new ones.

Or its just dead.

you could boot off Ubuntu USB and see if if can see it - https://ubuntu.com/tutorials/create-a-usb-stick-on-windows#1-overview
 
Jul 23, 2022
12
0
10
0
I think problem not in any update. Because sound dissapear after transortation and also PC has not internet connection. I thtought problem in not connected front panel, but no... May be Sound Card receive damage in trasportation time... Can be reason my new and very strange monitor Lenovo thinkvision 1680x1050?
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
58,129
4,718
161,190
10,348
I think problem not in any update. Because sound dissapear after transortation and also PC has not internet connection. I thtought problem in not connected front panel, but no... May be Sound Card receive damage in trasportation time... Can be reason my new and very strange monitor Lenovo thinkvision 1680x1050?
Was distance travelled substantial?
is internet problem new?
what is wrong with monitor?
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
58,129
4,718
161,190
10,348
Have you looked inside PC since it was moved?
it appears the front audio connector on motherboard just below the sound chips, it might help to look in case and see if you can see any damage.
if you look at page 7 of manual, the front connector is marked as 26
https://download.asrock.com/Manual/B450 Pro4.pdf
I am unsure where the LAN chip would be.
possibly in same area as sound. The gold line around the bottom left corner of baord meant to isolate the sound areas for electronic reasons. All sound chips are on the left of the line.

i doubt monitor caused the problem
 
Jul 23, 2022
12
0
10
0
Was distance travelled substantial?
is internet problem new?
what is wrong with monitor?
Im travelled from Ukraine to Norway.
Its no internet problem. I just have not internet connection in last living place.
IDK, i think all right, throught thats can be reason =/
 
Jul 23, 2022
12
0
10
0
Have you looked inside PC since it was moved?
it appears the front audio connector on motherboard just below the sound chips, it might help to look in case and see if you can see any damage.
if you look at page 7 of manual, the front connector is marked as 26
https://download.asrock.com/Manual/B450 Pro4.pdf
I am unsure where the LAN chip would be.
possibly in same area as sound. The gold line around the bottom left corner of baord meant to isolate the sound areas for electronic reasons. All sound chips are on the left of the line.

i doubt monitor caused the problem
ofc i have looked. And i didnt recognize somesthing bad.
 

ASK THE COMMUNITY

TRENDING THREADS