Realtek HD Audio doesn't recognize external devices

Manu92

Honorable
Dec 23, 2013
19
0
10,520
3
Hello,

I read a lot of posts but I still didn't find a way to fix my problem. I just re-installed my windows 7 and I can't get my speakers, my headphones or the earphones to work. Only the laptop internal speakers work. I have linux on my machine as well but everything works there. In Control Panel Sound Playback I can only see "Speakers" (internal ones). I don't know what else to try.

Suggestions ?!
 

2x4b

Honorable
Oct 28, 2013
775
0
11,360
185
Open up the device manager (from control panel) and look for any devices that have a little yellow exclamation point in their icon. It is possible that you still need to load some drivers.
 

Manu92

Honorable
Dec 23, 2013
19
0
10,520
3
Sorted it out. Apparently it gets into conflict with linux. Any kind of external sound devices are not recognized if I go into linux first then switch to windows. The only way is to shut down the laptop and go straight to windows after i turn it on.
 

bertnagastge1976

Honorable
Dec 26, 2013
3
0
10,520
1
Try this:

Disconnect the drive and open the Registry Editior (Start-Run-Regedit).
Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\V1394

Check under that key and see if you can find anything about your
firewire hard drive. If you do find a key, right click on it and change
the permissions to Allow full control. Now right click and delete the
key. Reboot and try plugging the device in again.
 

ASK THE COMMUNITY

TRENDING THREADS