Question Realtek HD Audio Driver giving me headaches

Mar 15, 2021
1
0
10
0
Hello guys!
I recently bought a new microphone for my setup like 4 days ago and since then, I am trying to make it working, and it's giving me a lot of headaches. It's a jack device and it's not detecting it, neither my speakers, only my headphones which they are USB. (Need to say that the jacks worked just fine then after reinstalling my windows)
From my thoughts I think I need to install the Realtek HD Audio Drivers or something, but they are not installing properly. In device manager, there is no other thing then my headphones (Razer Kraken 7.1 V2) and High definition audio manager, which was NVIDIA high definition something. It's creating a Realtek folder only in Program Files (x86), not in the normal Program Files and like I said, there is nothing in the device manager.
What have I tried to do :
Downgrading Windows 10 versions from : 20H2 to 2004, 1909, 1908, 1903 currently using 1809. (64 bits) Adding the driver as a legacy hardware, resulting into a BSOD. Installing Audio Jack Service from my mainboard facture (GIGAByte) resulting into error 1920. Uninstalling NVIDIA High Definition Audio
And so on, so I can't manage to solve it.

My PC specs :
CPU : AMD Ryzen 7 2700X GPU : NVIDIA GeForce GTX 980TI RAM : 16 GB RAM DDR4 3200 MHz Mainboard : GIGABYTE GA-AB350M-DS3H V1 SSD : 128GB HDD : 1TB
 

Ralston18

Titan
Moderator
This: "jack device".

Meaning a 1/8" (3.5mm) male plug - correct? TS, TRS, or TRRS?

Reference (if necessary):

https://www.cablechick.com.au/blog/understanding-trrs-and-audio-jacks/

What make and model microphone?

What audio port or ports did you try when plugging in the microphone?

Does the microphone appear in Device Manager? (Ensure, via "View" that "Show hidden devices" is checked.)

= = = =

Right click the small speaker icon usually found in the lower right screen corner.

You should first see an audio related menu with 4 or 5 choices.,

Each choice will need to a number of pop-up Windows, Tabs, and Properties.

Verify that all are set/configured correctly with respect to the audio devices and ports being used.
 

ASK THE COMMUNITY

TRENDING THREADS