Question Realtek not working & not appearing anywhere.

Apr 24, 2019
1
0
10
Specs:
MSI B360 Gaming Plus
Intel i5-8400
NVIDIA GeForce GTX 1050 Ti
16GB RAM
(Any other specs needed let me know)

My PC is nearly 1 year old, when I first built it audio drivers were working perfectly but after a couple months Stereo Mix and everything relating to Realtek just stopped working/disappeared and my two front 3.55mm ports stopped working. I can't remember how or if I did anything at all to get them to work againt but a few months after that they just started working again. In January I decided to format my PC but in doing so, it reverted my audio drivers/stereo mix/ports back to not working. I have been trying to figure out this issue for some time now and every solution I have come across hasn't worked for me.
I use a Blue Yeti Microphone and I have a small feeling that might be causing the problem but I have no idea why it would since it worked for months with no problems at all. I also think maybe there's something that can be done through the Registry Editor maybe but I doubt that's true. In addition one of the two "High Definition Audio Controllers" does not work (Code 10), maybe that has something to do with it but everything I've tried to get it working hasn't.

I've tried; reinstalling drivers multiple times, installing them from "clean boot", adding the driver to device manager through (Code 10), installing with Blue Yeti unplugged.
When I have tried to reinstall the drivers it hasn't changed anything.
Screenshots:

Realtek not appearing in Control Panel - https://prnt.sc/ng7l6a
But appearing in Programs & Features - https://prnt.sc/ng7t5o
HD Audio Controller - https://prnt.sc/ng7ly3
Realtek drivers not appearing in device manager - https://prnt.sc/ng7m2b
Recording devices (showing hidden and disabled devices) - https://prnt.sc/ng7mfh
Playback devices (hidden and disabled devices shown) - http://prntscr.com/ng7v6m

Any help is much appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS