Realtek onboard audio missing from device manager.

Jul 24, 2018
25
0
40
2
So two days ago I upgraded my system from AMD FM2 (DDR3) platform to AMD Ryzen platform.

My old specs:
Gigabyte f2a68hm-s1
Corsair CMV8GX3M1A1600C11
AMD ATHLON X4 860K

My new specs :
Msi B450M-PRO VDH
Ryzen 3 1200
Gtx 1060 3gb
4gb ram

I am using the same hard disk of my old system with Windows 8.1 64bit installed. I didn't reinstalled windows after changing motherboard.


Problem :
My speaker was working fine on my old system but it is not getting detected when I connect to new motherboard and I get no audio.
Also after installing realtek audio drivers it does not fix the issue. Then I checked the device manager and found that realtek audio was missing from device manager.
I tried installing and uninstalling driver several times but the onboard audio is not getting detecting by windows. Also after installing drivers and rebooting, realtek audio manager is also absent on control panel.
But the option to unistall the audio driver is available on control panel. Also my on broad audio are enable on Bios.

Please find pictures attached :
https://drive.google.com/file/d/1DHRDqbxKEoZZV5L13Rp1CswLm9G93y-3/view?usp=drivesdk
https://drive.google.com/file/d/1rrX1W8taOD0hyE0S75UJ7PyM2IvbFGeh/view?usp=drivesdk
https://drive.google.com/file/d/11gAUMVKVlgcaD9br9VG1N6GEWVaCKGuX/view?usp=drivesdk
https://drive.google.com/file/d/1mNoy8EbP0g1m9utYe31jalSh9cdlrVN_/view?usp=drivesdk
https://drive.google.com/file/d/1gMNQFaFZMh-X3O8gy22YURHhp_U79dkr/view?usp=drivesdk

Update:
I did a clean install to windows 10 but it didn't solved the issue. I also tried installing all drivers from msi Motherboard page but still no luck. Realtek audio is not getting detected by device manager.
 

boju

Champion
Could try installing audio driver direct from Realtek http://www.realtek.com/

Though, i don't like your chances, there's no chipset drivers available for Win 8.1.

You're better off biting the bullet and go Win10. Try do the upgrade.
 
Jul 24, 2018
25
0
40
2

Okay I will let you know after installing windows 10.

 
Jul 24, 2018
25
0
40
2


Update :-
I did a clean format and installed windows 10 but the problem still persist.
I installed AMD chipset driver and audio driver but no luck. Still realtek audio is not appearing on device manager and windows is not detecting any speakers.

Is it a hardware issue?


 

boju

Champion
Did you try replug the speakers so the connection is refreshed?

How about volume, is the bar going up and down?

Have you tried headphones?

Audio will still work without audio manager, its the driver that makes the audio work. Asus did remove audio manager from their latest drivers so people had to install older drivers to get it back, but your board is Msi, not sure if they did the same thing.

Maybe the board is faulty?
 
Jul 24, 2018
25
0
40
2


When I click Volume button troubleshooting opens as no playback device is available.
I disconnected and connected speaker many times.
Headphones also don't work.
I can understand it will work without audio manager. But in device manager it is not detecting realtek.

Yes the board maybe faulty.
 
Jul 24, 2018
25
0
40
2

I did a fresh clean install to windows 10 but it didn't solved the issue.
 

boju

Champion
Did you update bios? Loading bios defaults is recommended after updating or by clearing cmos, just helps new firmware data to re-enter cmos.

Or if you haven't updated bios, maybe try that.

You're probably right though, audio shouldn't be this difficult.
 
Jul 24, 2018
25
0
40
2


Okay, I will update the Bios and will inform you.

 

ASK THE COMMUNITY

TRENDING THREADS