Question Realtek PCIe GbE Family controller not starting. No Ethernet.

Mar 4, 2022
5
0
10
0
Laptop: Asus N53SM
OS: Windows 10

I have reinstalled windows 3 times, two of those times i didn't do a fresh install, but this last one i formated the drive and used a genuine Windows 10 iso.
I have installed all the drivers provided from asus and from windows update, but i can't get ethernet to work on this laptop. I know that it atleast did work ( i have used this pc for the last 4 years ).
Bios are set to default.

ALSO: booting into linux live boot, Ethernet works . It's windows that is giving me problems.

I am at a dead end, i have no idea what to do, to fix this.

 
Last edited:

Lutfij

Titan
Moderator
Use CPU-Z to see what BIOS version you're on at the time of writing. Cross reference the BIOS with that listed on Asus's support site, here. As for your OS, what version(not edition) of Windwos 10 are you working with at the time of writing? Did you recreate the bootable USB installer using Windows Media Creation Tools? using an older ISO isn't the way to go about reinstalling the OS, mind you.
 
Mar 4, 2022
5
0
10
0
Use CPU-Z to see what BIOS version you're on at the time of writing. Cross reference the BIOS with that listed on Asus's support site, here. As for your OS, what version(not edition) of Windwos 10 are you working with at the time of writing? Did you recreate the bootable USB installer using Windows Media Creation Tools? using an older ISO isn't the way to go about reinstalling the OS, mind you.
BIOS version 205, the latest from asus for this laptop
Windows 10 21H2 - Which i was on before this started to happen
Downloaded windows 10 iso from microsoft and put it on a usb with rufus. No aftermarket activators or patches. Clean win10 iso.
 

ASK THE COMMUNITY

TRENDING THREADS