Question Received my new gaming rig today. It won't post, did I break something?

moze85

Distinguished
Oct 20, 2012
10
1
18,515
0
Sad day for me. I waited a few weeks to get an 'almost' all-out gaming machine. It arrived today. I quickly swapped out RAM and attempted to boot it up... Booted right up to new Windows setup. All 64G showing up just fine.

I shut it down, took it downstairs, grounded my wrist to the chassis, and proceeded to remove the GPU and heat spreader over the m.2 slot on my Asus X570-E motherboard. I carefully installed a Gen4 M.2 drive, and then put everything back together.

All of the sudden, the system would not boot and no signal would make it to my monitor. After looking over the mobo manual, I saw that it in fact would not post, and was getting stuck at the memory check.

I tried everything... Ultimately, brought the system back to bone stock, reseated RAM, tried a single DIMM in every slot (with multiple sticks), reseated and reconnected GPU, attempted to reset CMOS, ensured screws were not too tight to mobo, reconnected everything connected to mobo, tried a different PCIE slot for the GPU, disconnected and reconnected everything to the PSU, etc.

Same deal. Amber light on the DRAM check no matter what I tried, including completely removing the GPU from the picture and also attempting with no RAM installed. Any insight into what's going on or what could have happened? Did I do this? Did the mobo just coincidentally decide to keel over after booting up successfully the first try?

I'm afraid I'll have to send this back, which sucks a great deal. Want to check here first. Thanks!
 

ASK THE COMMUNITY

TRENDING THREADS