Question Recently i changed my PSU to a Corsair RM850x but PC still shuts itself off ?

Sep 4, 2021
20
2
15
0
When i got this new one installed it went fine for 4 days playing Witcher 3 now suddenly my PC shuts off again. The issue happened with my previous PSU which was a CV650 at the time but people told me it wasnt strong enough to handle my i9-10900k and RTX 3080 so i bought the RM850x instead but the issues are still happening and it happens mostly when playing Witcher 3 and Alt-Tabbing out the game to browse the Internet etc...
 
Sep 4, 2021
20
2
15
0
What’s the full pc spec?


CPU: i9-10900k at 4.9ghz
CPU Cooler: Corsair H100i AIO
MOBO: Asus TUF B460 Plus (Yeah i know its a locked board im planning on changing it to a Z Board soon not sure if thats the issue or not)
GPU: EVGA RTX 3080
1TB Samsung Pro Evo 1TB NVME
2TB Seagate HDD + 8TB Seagate Ironwolf Drive
Case: Corsair ICUE 220T
 
Sep 4, 2021
20
2
15
0
You use three cables to power the gpu or just two? One where you use both connectors on it.

Might also try DDU to remove current drivers and test with the latest "Studio drivers" from Nvidia.

Funny enough i did have my GPU Daisy Chained. So i put 2 6+2 Pin connectors to the GPU tested again and it still happened. and i used DDU to clean my NVIDIA Drivers and updated them to latest to no avail.
 

Phaaze88

Titan
Ambassador
Optimized defaults would let the cpu boost normally though..?

Huh... I suspected the mobo might be crapping its pants with a 10900K in it. Maybe it still is though... it only happens in game, right?
Get a table or box fan, and aim it inside the chassis and try to run it again with Turbo Boost disabled.
 
Sep 4, 2021
20
2
15
0
Did you test with "Studio Drivers" as well?

Problem is when im playing witcher 3 and get to an intensive spot then Alt-Tab to watch Youtube Video while the game is running in the background after a few minutes the Display Driver Crashes and the game just closes with no error message
 

Vic 40

Titan
Ambassador
Problem is when im playing witcher 3 and get to an intensive spot then Alt-Tab to watch Youtube Video while the game is running in the background after a few minutes the Display Driver Crashes and the game just closes with no error message
Understand, but the Studio Version should be abit more stable than the game version as i understand and the one i'm using myself, There isn't a reall performance hit so can't hurt to try.

You use default resolution when playing?






Doesn't the EVGA have three PCIe power connectors?
Thought the same, but the "cheaper' versions have two.
 
Sep 4, 2021
20
2
15
0
Im playing at 4K Max Settings on my EVGA 3080 its only when I Alt-Tab out the game to browse around Youtube Videos i think the problem is because of Transient Spikes and causes my GPU Driver to crash. Im purchasing a Seasonic GX 1000w PSU and will see if that solves the problem. Ive heard the Corsair PSU,s in the UK have been pretty problematic. In fact the first time my issue happend with the RM850x Installed inside my PC my System flat out Shutdown and Restarted itself. Now all i get when i Alt-Tab out of Witcher 3 is just GPU Driver Crashes[/QUOTE]
 

Vic 40

Titan
Ambassador
i think the problem is because of Transient Spikes and causes my GPU Driver to crash. Im purchasing a Seasonic GX 1000w PSU and will see if that solves the problem. Ive heard the Corsair PSU,s in the UK have been pretty problematic. In fact the first time my issue happend with the RM850x Installed inside my PC my System flat out Shutdown and Restarted itself.
That is up to you, hope it helps.
 

ASK THE COMMUNITY

TRENDING THREADS