Question Recommendation for replacing BitDefender

leftisthominid

Honorable
Jan 7, 2014
342
0
10,790
4
I have a Gigabyte Aero 15 with BitDefender Total Security. I have recently come to notice that I get audio popping sounds when browsing the web and listening to music at the same time. I get it with Firefox, Chrome, and Edge, so it isn't from the browser.

Interestingly, it only occurs when I am using the RealTek audio built-in to my laptop's motherboard. When I am outputting audio over HDMI from either of my GPUs (Nvidia or Intel), the problem disappears. I tried changing my RealTek driver (as well as my Killer Ethernet/WiFi drivers) many times, but I had no luck in fixing it. Then on a lark, I tried uninstalling BitDefender, and then the popping went away. It appears BitDefender is conflicting with RealTek in some way.

When I disable Advance Threat Defense it goes away, but disabling that is problematic (so I re-enabled it). I originally thought it might have been the microphone monitor, but that is not the case. Does anyone have a similar problem? (Also, my BitDefender is expiring soon, can anyone recommend a non-Kaspersky alternative?)

This is one site that triggers the popping noises. It triggers over RealTek, but not over HDMI audio. It doesn't do it 100% of the time, but if I play music in the background and F5 enough times, I will hear pops.

Anyone have a recommended alternative?
 

Colif

Win 10 Master
Moderator
Do you have latest bios on laptop?
where are you getting the killer drivers from?

so bitdefender and kaspersky - the top 2 performers on most AV charts, are off the list? What I would do is run using defender only and see if the problem returns

For me it was BitDefender's port scanning protection feature, once I'd disabled that problems were gone.Try this: open BitDefender, go to Modules (in the bottom) > Firewall and there disable Block port scans in the network
https://www.tenforums.com/sound-audio/45971-sound-crackling-clicking-etc-when-playing-sounds-2.html
 

leftisthominid

Honorable
Jan 7, 2014
342
0
10,790
4
Do you have latest bios on laptop?
where are you getting the killer drivers from?

so bitdefender and kaspersky - the top 2 performers on most AV charts, are off the list? What I would do is run using defender only and see if the problem returns


https://www.tenforums.com/sound-audio/45971-sound-crackling-clicking-etc-when-playing-sounds-2.html
I have the latest BIOS. I have the latest Killer drivers from Killer's website. The drivers Gigabyte was providing were unsigned... I tried port scan disabling before, I have to disable advance threat detection to make it go away. If I uninstall it completely, it seems to go away.

I just updated my audio drivers to the absolute latest from Gigabyte's website (https://www.gigabyte.com/us/Laptop/AERO-15--RTX-20-Series/support#support-dl-driver [6.0.8924.1]). I followed their directions and disconnected from the internet during the installation, still pops. If I disable advance threat detection in Bitdefender (or uninstall Bitdefender), it goes away.

How is Norton?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS