Question Red Blinking GPU light? PC won't start?

Apr 5, 2020
4
0
10
0
So I recently purchased an RX 5700 XT gpu for my computer and attempted to replace my existing RX 580 with it. Nothing occurred upon power up - only a single red blink from an LED light on the new GPU when I attempted to power the PC on. I then proceeded to remove this new card and put in my old one (RX 580) and same thing! One red blink of the led light on the gpu and nothing. This occurs everytime I attempt to unplug the psu and plug back in, and press the power button - just a single red blink and nothing (absolutely nothing runs). I have made sure to remove all connectors and plug them all back in (ensuring they were all sat correctly), and I made sure the ram was connected properly. I also reset the CMOS by replacing the battery and waiting, and placing it back in.

Computer Type: Desktop
GPU: XFX RX 580 (currently in). XFX RX 5700 XT Raw II (trying to install once this issue is resolved)
CPU: Ryzen 5 2600x
Motherboard: MSI XR 470 Gaming Plus
RAM: 16 GB (2 x 8 corsair sticks)
PSU: EVGA 600 W 80plus
Operating System & Version: Windows 10
GPU Drivers: up to date drivers
Description of Original Problem: Review above
Troubleshooting: Review above

The only thing I think it could possibly be at this point is a shorted and now faulty PSU.. which has led me to order a new one.
 
Apr 5, 2020
4
0
10
0
well does it run and post without GPU?
if so its not a pSU issue, but if not i would suggest your taking the right course of action
Does not run and post without the GPU. Just bought a new power supply and replaced the old one. Still the same issue, no posting and the same red light appears on the GPU. I have tried these steps with both my old and new GPU, so i now know its not an issue with my GPU or with my PSU.. so now I have to lean towards the mobo.
 

ASK THE COMMUNITY

TRENDING THREADS