Question Red CPU light blinks 3 times on MSI B450 Tomahawk Max, PC not starting

Jan 28, 2021
8
0
10
0
Hi,

I bought an used PC whithout a GPU on ebay, and everything worked fine when the seller showed me some images (With the GPU installed of course). For testing purposes, i tried installing an old amd hd 7300 GPU to see if everything works, but it didn't turn on. I tried pressing the flash bios button on the back and the led next to it blinked three times, but nothing else. Could that be because of the old GPU, or is there a chance of another component being faulty? I couldn't find anything about the specific mainboard led codes in the internet.

CPU: Ryzen 5 3600X
Cooler: be Quiet! Dark Rock 4
Fans: 4x Corsair Air Series SP120 PWM Quiet Edition
Mainboard: MSI B450 Tomahawk Max
RAM.: Corsair Vengeance LPX 16GB (2x8GB) DDR4 3600MHz
PSU: 600 Watt be quiet! Pure Power 9 Modular 80+ Silver
Case: Corsair 275Q Carbide Series Mid-Tower

Any help or ideas to make this pc work would be much appreciated !
 
Jan 21, 2021
20
2
25
1
Ist Thing Ist
Disconnect PC from power source
Remove Any attached usb, mouse, speakerz , monitor cable

Open the side panel door
Just take out your memory sticks/ram and plugged them again in mobo carefully

Check all the cables are properly connected to board.

Close the panel door
And Give it a try
In Many of cases. Its easy fix
 
Jan 21, 2021
20
2
25
1
Try one ram stick one by one to find any 1 is faulted.

If you wil not able to get display
Then
Remove memory sticks
Turn on
Motherboard should beep for ram absence to find if memory stick is the cause
 
Jan 28, 2021
8
0
10
0
Hello,

I bought an used PC whithout a GPU on ebay, and everything worked fine when the seller showed me some images (With the GPU installed of course). It arrived, but when i try to turn it on, the ez debug led for the CPU turns on. I've tried to reseat the CPU several times and couldn't find any obviosly bent pins or something like that. When i tried to install the ram in another system, i got the Bluescreen of death error code "IRQL_NOT_LESS_OR_EQUAL", but upon restarting, it seemed to work just fine.

CPU: Ryzen 5 3600X
Cooler: be Quiet! Dark Rock 4
Fans: 4x Corsair Air Series SP120 PWM Quiet Edition
Mainboard: MSI B450 Tomahawk Max
RAM.: Corsair Vengeance LPX 16GB (2x8GB) DDR4 3600MHz
PSU: 600 Watt be quiet! Pure Power 9 Modular 80+ Silver
Case: Corsair 275Q Carbide Series Mid-Tower
GPU: amd hd 7300 (for testing)
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS