Question Red CPU light, no post, worked yesterday.

Feb 16, 2021
3
0
10
0
Hi, I woke up this morning and went to start my computer and it would not boot. I checked the motherboard lights and the red CPU light is on.

Went through the basic troubleshooting of checking cords, fans, etc and got nothing.

Eventually came to the conclusion that it must be the cmos battery being faulty. Got a new one and still a red CPU light and no post.

We did have a storm yesterday but the power never went out at our place. I don't know what else it could be other than the cpu randomly dying. All other computer parts seem to be working fine (have power, GPU fans start on boot, motherboard has lights working, disconnected ram and got vram light on motherboard reconnected it and it the vram light went away.

I am lost for what could be the problem. This is a relatively new build (2 months old) but has been working fine since I built it.

Any help is greatly appreciated.

Cheers.


Specs:
OS: Windows 10
GPU: nvidia 3080
CPU: Ryzen 9 3900XT
MB: Msi b550 tomahawk
Ram: 2x16GB G.skill ripjaws V
PSU: ASUS ROG STRIX 850G 850W Gold Power Supply
 
Last edited:

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Include PSU: make, model, wattage, age, condition.

Power down, unplug, open the case.

Clean out dust and debris.

Double check by sight and feel that all connectors, cards, RAM, jumpers etc.. are fully and firmly in place.

Inspect connectors for signs of damage, bare conductor showing, pinched, kinked, loose in the socket, wires, etc..

New builds can be a bit tricky. No one wants to force a connection so something may not have been completely connected. So, due to expansion and contraction the connection just worked loose.
 
Reactions: Frostaid
Feb 16, 2021
3
0
10
0
Updated specs.

The build is literally 2 months old. Very little to no dust, double checked all connectors, unplugged and replugged them to be sure, no damage anywhere to be seen. Even reseated the ram and cpu to ensure that there was no damage anywhere.

All fans are working, all components seem to be working outside of CPU.

Was working fine for the last two months, randomly had this issue today.
 
Feb 16, 2021
3
0
10
0
No beep codes?

Are you able to get into BIOS?

Will the the computer boot into Safe Mode?

Does the following link provide the User Guide for your motherboard?

https://download.msi.com/archive/mnu_exe/mb/E7C91v2.2.pdf

(Do vVerify that I found the correct manual.)

And the red LED you see is the CPU per physically numbered Page 41?
No beep codes I believe (currently running out to get thermal paste to try swapping CPUs with Gf's pc.)

Won't boot into safe mode nor can I even get to bios.

Thst is the correct manual and yes that is the correct LED.

Have currently tried swapping out ram and PSU with Gf's computer. Going to do cpu later tonight. No far no solution.
 

ASK THE COMMUNITY