Question Red Dragon 5700 XT no display, unable to POST into BIOS, but fans spin and backplate gets hot. What could cause this, besides a faulty GPU?

noah_mattox

Reputable
Aug 15, 2016
2
0
4,510
0
Bought a PowerColor Red Dragon 5700 XT in August that was DoA, just received the RMA replacement and it's exhibiting the same issues from the title. I've never gotten so much as a display signal or a flicker of life from this thing, but I know these cards are finicky and it's unlikely that I would receive two broken cards in a row. I took the GPU to a local PC repair place to have it tested and they said it was seemingly dead, but there are a number of things that could cause this card to play dead when it's not. That being said, the GPU is almost certainly defective, but I'm hoping someone more knowledgeable than me could possibly help.

I've ran through just about every troubleshooting step imaginable, including those sent to me by PowerColor support. Updated my MOBO BIOS, reseated RAM and GPU more times than I can count, tried every combination of PCIe connectors, VBIOS, and UEFI/Legacy settings in BIOS. Uninstalled all drivers with DDU and reinstalled correct AMD drivers. Cleared CMOS. I even went as far as reinstalling Windows on a fresh SSD and nothing. Logic would dictate that this is another dead card but it does show signs of life, so I'm not sure. The fans spin intermittently and the backplate starts roasting if I leave the machine on. If it's a cold boot, the system will enter a power loop where it seemingly fails to POST 3-4 times, until eventually the CPU runs as if the system is booted. But the USB peripherals always fail to light up and I've never gotten any semblance of a display signal.

I've pretty much narrowed it down to a couple of possibilities, assuming the GPU is not dead. Since it doesn't even reach the BIOS, I don't think it can be a driver issue because the relevant drivers aren't loaded until Windows has booted. I'm also pretty confident that it's not my power supply, as I have a Corsair CXM Gray 650w that meets the requirements and then some. There are two separate PCIe connectors, so I'm not daisy-chaining, which is known to cause issues. It seems to me that it must be an issue with the Boot settings in the MOBO BIOS, but I've read a lot of conflicting information about this regarding the 5700 XT. I know that it's UEFI only, and I've read that Power Save, CSM, and Fast Boot settings can mess with the 5700 XT under certain conditions. But that is the extent of my knowledge, I really have no idea what exactly is happening when a GPU fails to POST. I guess it could be an insufficient PSU but the general consensus is that this PSU is more than sufficient.

Also, important note: My system works perfectly with my other GPU installed (Sapphire Nitro+ RX 480 4GB.) So it's almost certainly not a hardware issue with my MOBO, and the numerous tests I've done with the 5700 XT have not damaged or affected the rest of the system in any way.

Hardware for reference:
CPU: Ryzen 3700 X
MOBO: ASUS B450m TUF Plus Gaming (BIOS v2409)
RAM: PnY Anarchy-X 3.2hz 2 x 8GB
GPU: PowerColor Red Dragon 5700 XT
PSU: Corsair CXM Gray 650W

Let me know if I need to post more info. I'll be active in this thread. Some last notes, I have only tried this GPU with one HDMI cable and display. Dunno if either one could cause this
 

ASK THE COMMUNITY

TRENDING THREADS