• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Red flashing light on MOBO for CPU and Monitors won't display anything

Oct 8, 2019
2
0
10
0
I was up last night and shut off my Computer properly, this morning when I went to turn it on the Screen froze on startup so I restarted using the power button on the chassis and then the monitors won't showing any input. The red light labeled CPU was red and flashed every 5-6 seconds. All my cables are plugged in properly, I have run RAM tests, moved the GPU between express slots and still no luck. I'm not sure what is going on but I need help fixing this issue as everything in the PC lights up and all fans are working but I can't identify the problem as it happened suddenly and I have been using this PC for a year now. I removed the heat sync to reveal a bunch of dust even on the CPU itself as well as some thermal paste between the CPU and the motherboard, not sure if this could prevent the computer from properly booting but will remove tomorrow and remount once the thermal paste arrives at my house.

Specs:
CPU: Ryzen 2600X
MOBO: MSI X470 Gaming Pro
Memory: G-Skill Trident 16gb DDR4 3200
GPU: MSI GTX 1070ti 8gb Gaming
PSU: EVGA 550W Supernova

Here are some pictures of the condition I found my CPU in:
https://ibb.co/897WG3C
https://ibb.co/PmVfvPj
 

cin19

Titan
Moderator
not sure if this could prevent the computer from properly booting
Maybe. Try to use the new paste ( don't add too much the pasta, you did add too much. If you want, you should watch some youtube online for how to ), and clean up these old paste too. Make sure to clean the CMOS before you try to boot the PC.

If you still have the same problem, I think either the CPU or MB may have problem, because the red light labeled CPU was red.
 
Reactions: omairasde
Oct 8, 2019
2
0
10
0
Maybe. Try to use the new paste ( don't add too much the pasta, you did add too much. If you want, you should watch some youtube online for how to ), and clean up these old paste too. Make sure to clean the CMOS before you try to boot the PC.

If you still have the same problem, I think either the CPU or MB may have problem, because the red light labeled CPU was red.
Thanks, I will be cleaning the CPU tomorrow and resetting the CMOS as well just hope that solves the issue :)
 

ASK THE COMMUNITY

TRENDING THREADS