Question Red led on Motherboard

Jun 23, 2020
27
0
30
0
I have msi mp5 b550 gaming edge Motherboard , there is always a red light stays on and it indicates cpu and my system sometimes doesn't start and sometimes it start and my ram slots were in A1 and B1 . but from few days when i change ram slots to A2 and b1 red light goes off and computer works everytime ? What could be the problem ? Plz don't tell ram slot is faulty as my pc works for 1-2 days then suddenly it stops till i remove and put ram back but red led shows error in cpu .
 

piechockidocent9

Reputable
Aug 30, 2017
162
16
4,765
25
Like GarrettL said. If that doesn't help run memtest86 for 0,5 to full hour for each stick, I know what you said and I agree that memory is probably not the issue but it won't hurt to check and have 100% certainty. If test won't pickup any errors the most probable suspect is ur motherboard, much less probable but still possible are cpu and power supply. Unfortunately it's hard to tell by other means than swapping compatable parts which you probably don't have. At that point I'd opt for you to visit nearest pcrepair point or send ur motherboard via warranty if it's still valid.
 
Jun 23, 2020
27
0
30
0
Like GarrettL said. If that doesn't help run memtest86 for 0,5 to full hour for each stick, I know what you said and I agree that memory is probably not the issue but it won't hurt to check and have 100% certainty. If test won't pickup any errors the most probable suspect is ur motherboard, much less probable but still possible are cpu and power supply. Unfortunately it's hard to tell by other means than swapping compatable parts which you probably don't have. At that point I'd opt for you to visit nearest pcrepair point or send ur motherboard via warranty if it's still valid.
Okay now I'm getting confused , i tested another scenario ,
when i put In
  1. A1 and B1 there is led light pc don't start
  2. A1 single stick no red led pc runs fine
  3. A2 and B1 no red led pc runs fine
  4. A2 and B2 only one ram stick runs no red light
5 th My Motherboard is msi b550 gaming edge
It runs dual channel in A1 and B1 as per website and manual so it's obvious if i put in A2 and B2 only one will get recognised .
😭nw help plz

Update
I put in A1 and B1 this time no red light pc booted fine and it's in dual channel but when i wikl restart the pc after few hours same problem will come
 

piechockidocent9

Reputable
Aug 30, 2017
162
16
4,765
25
Your motherboard is probably busted and unfortunately in a bad way. Usually you could put a single ram stick in each slot and try it out to rule out which slots are fried and which are working. However with how random it looks in ur case and with all the slots it's most likely game over. All you have is warranty at this point or buying a new motherboard if ur past warranty period. Damaged ram slots are not exchangable or repairable.
 
Jun 23, 2020
27
0
30
0
Your motherboard is probably busted and unfortunately in a bad way. Usually you could put a single ram stick in each slot and try it out to rule out which slots are fried and which are working. However with how random it looks in ur case and with all the slots it's most likely game over. All you have is warranty at this point or buying a new motherboard if ur past warranty period. Damaged ram slots are not exchangable or repairable.
No my mobo is fine and it's working normal don't know what fixed it but all ram slots working fine :)
 

piechockidocent9

Reputable
Aug 30, 2017
162
16
4,765
25
Heh well now I'm confused, happy for u sure but nevertheless consfused. I'm hoping it will stay in workin' condition though if the problem returns I'd still opt for smthing wrong with mb. Other than that I've got nothin' aside from maybe checking ur cpu and it's cooler for tight, correct fitting. Cpu getting loose is the only other thing coming to mind that I'd associate with this sort of issues.
 
Jun 23, 2020
27
0
30
0
Heh well now I'm confused, happy for u sure but nevertheless consfused. I'm hoping it will stay in workin' condition though if the problem returns I'd still opt for smthing wrong with mb. Other than that I've got nothin' aside from maybe checking ur cpu and it's cooler for tight, correct fitting. Cpu getting loose is the only other thing coming to mind that I'd associate with this sort of issues.
Yeah seems so , I'm getting new cooler tomorrow :D will put that one
 

ASK THE COMMUNITY