Question Refresh rate lowers when in certain windows


Mar 8, 2011
Is there any reason why a particular program or window would cause my monitors refresh rate to lower? I'm running Windows 10 and the monitor itself is a 144hz MSI MAG321CQR. I first noticed the issue when adjusting audio recording settings in Elgato Wave Link, where an animated window within a window within a window caused the refresh rate to drop down to the low 40's, and back up again causing a subtle flicker. I closed Wave Link, then inside the application properties I selected "disable full screen optimizations", and this seemed to do the trick. Now a second time when running Davinci Resolve I had the same refresh rate drop, closed the program, and disabled fullscreen optimization. This however did not work, still causing the slight screen flicker.

Are there any additional programs or settings that would cause this on an app by app basis? I also have an RTX 3090, and it run games just fine so I believe things are well and good on that front.
Any recommendations would be welcome.

Thank you

Forgot to mention that when Davinci Resolve is flickering, I can shrink the window and click anywhere on the desktop or taskbar and the refresh rate will stay put at 144. Clicking back on Davinci Resolve brings the flickering again.


I also have an RTX 3090
Can you please pass on the specs to your build like so:
include the age of the PSU apart from it's make and model.

You might want to also check and see what your BIOS version for your motherboard is. As for your GPU, try and use DDU to uninstall all GPU drivers, then manually reinstall with the latest GPU drivers from Nvidia's support site, in an elevated command, i.e, Right click installer>Run as Administrator.

Are you using the driver found here;
It may be an issue with the application triggering G-Sync, since I've seen similar behavior before. I leave G-Sync on full screen only since Windows will force triple buffering + VSync on windowed (including fullscreen borderless) apps anyway.

Or you can disable G-Sync outright if you don't need it.