Question Refreshed Build Reboots at Windows 10 Logo Prior to [USB] Installation

Jun 18, 2020
1
0
10
0
Hey everyone,

I have a Gigabyte GA AB350 Gaming 3, Ryzen 1600, RX580 that I am trying to install windows to for someone. I was previously using this computer with the same RAM and CPU, but have installed a new GPU and power supply, as well as new SSD and HDD. Thus, needed to install Windows 10- but as soon as it hits the logo to install, the computer restarts.

I made a windows 10 USB via both creation tool and Rufus. The PC posts, and I can get to bios, but when the PC gets to the windows install logo, it instantly reboots repeatedly.
I'm at my wit's end. I've tried messing around with bios settings, but whether I do this via legacy or UEFI the same thing occurs. I've tried reseating and replacing ram, even using just one stick at a time. Can anyone lend some insight?

I've also tried a different thumb drive, wonderin if perhaps the stick was bad. I've remade an image a handful of times now.
 

ASK THE COMMUNITY