Question Reliable Acer 7551G -> Black Screen After New CR2032 BIOS Battery

Nov 30, 2020
1
0
10
0
Hello everybody,

I'm asking for help here because no matter what I think I know, there's somebody out there that knows better :)

=====

So, here's the setup:

My laptop is 11 years old and has never failed me. This is not me complaining about how bad Acer laptops are or anything like that.

The initial setup included an AMD Phenom X3 CPU , an HDD and 4 GB or RAM.

Over the course of time, I have upgraded to 8 GB of RAM and a few different SSDs. They all work fine.

The laptop was so good, stable and reliable that I have used it continuously (as much as you use a semi-DTR that sits in the dining room most of the times and leaves with you on some holidays) since back in 2009.


=====

Repairs done : new laptop battery sometime in 2015 and a new keyboard in 2013 (because of a broken key) and constant cleaning of the dust in the heatsink.

For the past 5 or 6 years, I've noticed that the BIOS would not hold its settings, therefore the battery was dead, but that did not annoy me too much as the laptop would work just fine.

Anyway, now with the lock-downs, I've concluded that there is no reason for me not to take some time and put a new CR2032 BIOS battery in.

I have disconnected the charger, took out the laptop battery, took out the screws and replaced the battery.

I've then turned the laptop back on and .... BLACK SCREEN .. :( as no good deed goes unpunished.

======

Symptoms:

I can hear the fans turning on. They are still being temperature controlled, as they spin down in a few seconds, when the radiator is not hot yet.

I hear the DVD-RW drive spinning and repositioning its lens actuator.

The power led is on.

No sounds, no beeps, nothing else.

=====

What I have tried:

Start the laptop with no RAM, no SSD, no WiFi Card, no DVD drive.

Start the laptop with only one SODIMM occupied : first DIMM0 then DIMM1

Take the CR2032 battery back out and leave the laptop for 30 minutes and then try again.

Check the battery voltage: 3.12 volt on the new one, 0.23 volt on the old one

Put the old battery back in and try, same result.

Put the new battery back in, same result.

Tried several times to power it up using also a VGA monitor.

========

So .. please ..if anybody has any idea, please let me know.

I don't suspect it is a "corrupted BIOS" as many say in other forums, because I was not doing a BIOS update, nor did it do this on its own (it did it only when I've put in the new battery)

Therefore I would not risk trying to re-write the BIOS using some boot-able USB ...

What I do suspect is that the BIOS is unable to complete the POST or it is unable to load the setup-defaults, but I don't know if there's a keyboard key combination to directly proceed to loading the BIOS defaults.

Honestly ... this technical issue is frustrating me and I don't like wasting a laptop, just because I can't figure it out :(

If the GPU would be dead, or smoke came out of the DC in jack ... ok ....trash it ... but this ?!?! This is really upsetting.

If it helps, I have also sourced the electrical schematics of the notebook and the manual. (not sure how to attach then to this)

Thanks a lot , for any ideas or suggestions.
 

ASK THE COMMUNITY

TRENDING THREADS