Remote desktop eats ALT key

robertbth

Distinguished
Feb 2, 2009
2
0
18,510
My ALT key doesn't work when I remote desktop to my Linux machine (via xrdp). My ALT key works perfectly from my other Linux machine (via xtightvncviewer), but using Windows's "Remote Desktop Connection" seems to consume the ALT key in some circumstances.

Cases in which Remote Desktop passes the key:

■ALT-arrow, e.g., ALT-left
■ALT-shift-anything, e.g., ALT-shift-, (i.e., ALT-<)
■ALT-specialkey, e.g., ALT-PgUp

Case in which Remote Desktop does not pass the key along:

■ALT-unshiftedkey, e.g., ALT-f
■ALT-space

I determined this by running xev in the remote X session. The pressing and releasing of the ALT key is properly caught in all cases, but only with Remote Desktop, when ALT is depressed, does the subsequent key (either space or an unshifted alphabetic character) get suppressed. vncviewer on Linux sends all characters.

Can this misfeature of Remote Desktop be fixed? Is there something in Vista, perhaps through the registry that can be tweaked to force the characters to be passed through?

Thanks.
 

robertbth

Distinguished
Feb 2, 2009
2
0
18,510
I discovered that if, after an RDP session is established on a particular port (e.g., 5910), that if I use the TightVNC client to connect, ALT works. (Sadly, other certain key combinations (e.g., Ctl-K) do not.) I still don't know how to fix all this.

Maybe the way to go is to use Remote Desktop Connection (Terminal Service) to first establish the session and then reconnect using a good VNC client. (Finding a good VNC client seems to be the next hurdle, then.)