Question Replace wireless card and there is no power

nickel beer

Sep 14, 2012
Good day all,
I own an Asus TUF504 laptop with the following specs

Intel 8th Gen 6 core/12 threads
RAM 32 GB DDR4 2666
1 TB Samsung 970 M.2 NVME
2 TB Team Group SSD
Nvidia 1060 video card

It works. It has worked and is not broken but I hate the slowness of the existing wireless card so I replaced it with a new Intel Wireless card.

My process is:
Remove power cord
Unplug battery
Undo screw holding Wifi card in place
Remove card
Replace with new card
Replace screw
Reattach battery cord
Replace power cord
Attempt to power on

It powers on with the old card but does not power on with the new card. I even tried removing the Samsung 970 NVME drive and replacing it with the Patriot Scorch I have been running on for years before i began this upgrade.

The M.2 drive works just fine with either drive in the slot but the wireless card only powers on with old wifi card and the new wifi 6e card will not let the system power on for some reason.

Does anyone have an idea what to check next?