Question Replaced both fans, updated graphics card utility, now only one spinning + no RPM control (EVGA RTX 2080 XC)

Jul 17, 2021
1
0
10
0
Greetings!

Thanks in advance for any help fixing this.

One of the fans on my EVGA RTX 2080 XC started making noise as the bearing went out about a year and a half ago. It got worse and worse, and after going back and forth with EVGA on their website and having them want me to RMA it when it was no longer warranty covered, I decided to look up the fan model and replace it myself.

I found the exact fan model (Power Logic DC Brushless Fan Model PLA09215S12H - H.Y. Bearing) on a website, ordered it, and identical fans showed up. From the pins to the blades to the tag on the back, everything was identical. I replaced both of them and upon initial boot up both fans turned on just like they should.

Upon loading EVGA Precision X1 - the utility that I use to build a fan curve so they aren't blasting at 100% and they go up in RPM slowly with a 600ms delay - it told me I needed to update to the newest version of PX1. Upon updating, my 2nd fan (the one "further" from the back of the PC) is no longer spinning at all and all fan control within the utility doesn't seem to work. The utility no longer reads fan RPM, although it claims to know how much power each fan is receiving - currently both fans are receiving 40% power but showing 0 RPM, even though the one fan is audibly spinning at max speed. I also tried running Furmark to stress test to see if getting the card nice and hot might turn on the 2nd fan - that didn't work.

I'm not running into overheating problems yet, and obviously the card is now running quieter due to the fan replacement, but I'm still a little frustrated that I haven't been able to get things fixed.

So far I've tried:

Uninstalling EVGA Precision X1

Rolling back Precision X1 to the previous one that worked fine that was installed when I did my initial boot post-fan replacement.

Running Driver Cleaner and reinstalling my nvidia drivers.

Checking my card's firmware to make sure it was up to date - it appears to be, but I'm not sure if you can "reinstall" firmware.

-

Any tips would be incredible welcome. Again, the oddest part is the fact that both fans were spinning just fine upon the initial boot after the replacement. It wasn't until an update on EVGA Precision X1 that it went to only 1 fan spinning, and nothing I have tried has fixed it yet.
 

ASK THE COMMUNITY