Replaced heat sink /fan...now wont POST...what did I break?

zenthor

Distinguished
Oct 14, 2008
6
0
18,510
I decided to switch heatsink / fan on my Intel Quad q9550 from stock to the Zalman. My Motherboard is Asus Rampage Forumula and was working fine before I started. When I installed the Zalman, MB would not post. All case lights, fans came on, but no beeps and screen stayed blank. Only light I noticed missing on MB was the CPU voltage one which is color coded for normal, high, crazy...it had no light at all. I tried redoing the zalman, checking all connections...still...no POST. So, I then took the Zalman off and replaced with the stock. Nothing. I tried basic troubleshooting like taking all RAM out, put one in at a time...clear BIOS jumper...etc.
So, what is the most likely thing I broke, MB or CPU? Since all lights (except the one) on MB works...HD, GPU, fans click on...I think MB is ok?
Can anyone think of cheapest way I can test? I do not have another 775 MB and do not know anyone that does. Only pc repairs in my area are Geek Squad...dont know if I trust them. Also...anyone have experience with returns with ASUS or Intel? Am I likely to get either replaced? Both are less then two months old. Thanks for advise!
 

BigBurn

Distinguished
Jan 24, 2008
192
0
18,690
I know you said you checked all the connections, put did you unpluged/repluged all of them? Somtimes repushing isn't enough. Especially recheck the 4pin that goes to the CPU. Everything after those steps are out of my league XD

Did you tryied to contact ASUS to ask them what could possibly be the culprit of that light beeing off?
 

V3NOM

Distinguished
Jun 18, 2008
2,599
0
20,780
well i was going to say maybe bad timing and corrupt bios or something but them boards have dual bios lol... maybe you hit or unseated something or? that is seriously weird..