[SOLVED] Replaced motherboard, no display

Jul 7, 2019
2
0
20
1
Recently I have bought two Esonic G41CPL motherboard. It supports LGA775 Socket Core 2 Quad, Core 2 Duo, Pentium and Celeron Processors and 1333MHz RAM. My CPU is Core 2 Duo E8400 which was working properly with Previous Intel DG35EC mobo. But the problem with G35 graphics is, it frequently restarts with BSOD no matter which OS i use, 7, 8, or 10. So I bought G41CPL, installed processor, RAM, and other stuffs. The new RAM is 1333Mhz 4GB TwinMOS. Then I powered it on but no display. Some scenarios are:
  • Onboard mobo lights working properly
  • Mouse lights up for once at start then goes away
  • Keyboard does not lights up at all
  • Processor fan is working properly
  • Processor is getting heated within seconds when tested without fan
  • The mobo beeps when no RAM in installed
  • Tried removing and replacing cmos battery
  • Tried resetting the CMOS
  • Tried taking mobo out of the casing, placing it on a plastic surface/foam and short it with a screw driver with only cpu, fan and ram
  • Tried using different monitor
  • Tried using a Core 2 Duo E7200 which was also working on previous mobo
  • CPU is pinless (so anything to look for bent pins?)
  • Scenario is same for both motherboard; in both of them, i installed Core 2 Duo E8400 (which officially supports 1333 Bus)
  • Tried cleaning RAM and RAM slots (this is unlikely to be the case, as both ram and mobo giving same problem)
  • One PSU is new, and the other one is working old, (same scenario for both)
  • Please Let me know if other infos are required
Specs:
  • Esonic G41CPL (Previous was Intel DG35EC)
  • Intel Core 2 Duo E8400
  • TwinMOS 1333MHz 4GB
  • Other stuffs
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS