Question (Request) original bios HIS RX580 XTR Roaring turbo 8Gb

Mar 17, 2020
1
0
10
0
hello, as I just bought an ex mining card and try to search for the original bios but cant find it anywhere even techpowerup vga bios collection. best I could find is the IceQ X2 OC model but when I tried it say "subsystem unmatch"
issue of my card are:
_sometime have output sometime dont (only when start the computer, can recognize by the HIS LED on the card, when it have output it work fine until second issue)
_Blue screen of dead randomly, my window just corrupted by that ( could be the cpu OC but I dont think so), I used HDMI, havent tried different port
- So after the BSOD, the reinstall window crash while boot into window for the first time, the ssd is not recognize by the board (bios), I left if for a day as I need go to work then it recognize now, but i am not sure if anything wrong with ssd
I also tried switch to other bios but it have the same issue

Now I am trying to reinstall window and try to flash the gpu back to original bios first to see if all the issue came from it or the others

or if by any chance that anyone have the same model just used for game, could I please have a copy of the bios file please?

my system:
ryzen 5 1600
x570i gigabyte pro wifi
corsair vengene rgb pro 3600mhz
gpu as is
Corsair SF600 600w PSU
https://photos.app.goo.gl/QfLYitp4MTvg7fmd7
Thanks for your support
 
Last edited:
Apr 22, 2020
3
1
15
0
Flash with AtiFlash using command prompt as Administrator (atiflash.exe/amdvbflash.exe -f -p 0 bios.rom)

-f means force flash to bypass subsystem unmatch
-p 0 is your gpu pci id (check with atiflash.exe/amdvbflash.exe -i) command
bios.rom is any bios file end with .rom format
 
Reactions: kinkara

ASK THE COMMUNITY

TRENDING THREADS