[SOLVED] Requests help please

Jan 29, 2021
9
1
15
0
Pc specs:
Cpu: i5 6400
Gpu: gtx 1050 2gb
Motherboard: h110m pro-vh
Ram: 1x8gb Corsair Vengeance
Storage: Wd Blue 1tb and a Crucial bx500 ssd 240gb
Psu: PowerOn PS-530W
Windows: Windows 10 pro
Pc was bought at 2015 except from gpu that was bought at 2016,ram at 2018 and the ssd at 2019
Problems:
So my problem is that while let's say browsing trough google it lags for multiple seconds and then turns back to normal, also when watching a youtube video it stops playing lagging the whole page and the sound keeps playing while everything else is stopped those are the problems I've had with google but also while I am playing games like csgo that before i would play on high graphics and get more than 60 fps, now I get those terrible fps drops like real terrible for 15 sec at 5 fps,walking around a corner getting 10 fps and when trying to change the settings my game just crashes and other big performance issues. I would like to possibly know what is the problem here.(If the information is not enough ask for more please).Thanks in advance.
 
Jan 29, 2021
9
1
15
0
I would think looking at your machine that the PSU has done a marvellous job but it is 5 years old and my recommendation would be to look for a new one my recommendations would be Seasonic / EVGA
Thanks i was looking for a new psu as well cause I was like 5 years for a cheap one at that i have to do something, I will get a new one probably thanks :D.
 

ASK THE COMMUNITY

TRENDING THREADS