• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

[SOLVED] Resolution stuck at 640x480 when using DisplayPort, works fine with HDMI

AristosT

Honorable
Jun 18, 2015
35
2
10,535
0
Ηello, my monitor and pc worked fine until I downloaded the latest nvidia driver (471.11) and then my monitors resolution was stuck at 640x480. I'm using an RTX 3090 and my monitor is a gigabyte aorus FI27Q ( 2560 x 1440 is my normal resolution) and I've tried using DDU to uninstall the drivers and reinstall them, the resolution is fixed and then when drivers are installed it goes back to 640x480 and I can't change it. NVIDIA control panel and the monitor's software (OSD Sidekick) don't open when the resolution is stuck at 640x480. I've tried restarting, reseting the monitor nothing works. When I plug the GPU with an HDMI, everything works fine, the resolution is 2560 x 1440, I can open the NVIDIA control panel and the monitor's software ( OSD Sidekick). Tried unplugging and replugging everything behind the monitor, didn't work. One thing of note, I saw on a forum that the drivers from a new phone that got plugged in your pc can cause issues like that, and 1 month ago I got a new phone and plugged it in to transfer some photos to my pc, only after that this problem occured, I also can't find the drivers of the phone in the device manager to unistall them. Anything of help would be greatly appreciated, thanks in advance.
 

ASK THE COMMUNITY