[SOLVED] [Resolved] Blue battern graphics glitch while booting or using a web browser in Windows (anything really)

Apr 16, 2021
It’s a graphics glitch so I’ll post here, but I’m not sure if it’s the outcome of some other issue.


It’s a Laptop

NVIDIA GeForce GTX 1060

Temperature while doing menial work: ~45-50 °C
Temperature while playing: ~60 °C (not a resource hog game)

Intel i7-7700HQ CPU @ 2.80GHz 2.80GHz

Temperature while doing menial work: ~55 °C
Temperature while playing: ~60-70 °C (not a resource hog game)

32 GB
Ran memtest86 for around 5 and half hours (I’ll talk about how this happened)

The issue started while I was doing non processor intensive work. You can see the image below. The error gives the impression of being random. Sometimes it can run for many hours, sometimes it takes 15 minutes to manifest the issue.

The issue is:
  • A blue pattern graphics glitch (almost always present)
  • Black screen (when the blue glitch does not manifest)
  • Screeching sound when the sound output is laptop’s audio device
  • Freezes
  • No BSOD (Blue Screen of Death)
  • Happens watching a YouTube video or playing a game or working in anything really
  • Takes many hours or a few minutes after booting
  • Happens while booting
  • Happened while running memtest86 (CPU temp went to 80 °C but dipped down quickly)
  • Nothing in events
    • It’s like it never happened
  • Sometimes Windows suggest some diagnostics after booting (restore/reset, etc)

Note: this image shows the glitch happening while booting the PC, although this also happens while doing any work in Windows, being it web browsing or playing, or using Photoshop, or Unity, doesn’t matter.

This image is of when it happened during memtest86 (one if the times I tried running it)

What I tried:
  • Changed thermal paste for both CPU and GPU. Used MX-4 from Arctic
  • Used compressed air to clean the fans; they were a bit dirty tbh
  • chkdsk - it found issues, and fixed them
    • After this I could run memtest86 for more than 5 hours, and the computer ran for around 11 hours straight, next day it took 30 mins to glitch again.
  • sfc /scannow - nothing found
  • Restore - didn’t help
  • memtest86 - ran 4 steps for around 5 hours - no issues. Should I try to run for more? I've seen that it has at least 4 steps more.
What I considered but didn’t try:
  • Resetting the BIOS
  • Resetting Windows (reinstall)
Weird behavior after the glitch: sometimes when I try to turn it on after it happens, the power supply seems a bit funnicky. It turns on and off for a few times, like a reboot loop state.

What I noticed: If I insist on turning it on after the glitch, it happens more often, while booting, or right away after I login or after a few minutes. If I give it some time it takes a bit longer and Windows does not suggest a restore/reset or other options.

I’ve read that it might be some power supply issue as well, but I don’t have much experience with those issues.

What else should I do? Is there a log somewhere I’m missing?
Last edited: