[SOLVED] RESOLVED - How to stop windows re-installing drivers automatically

Status
Not open for further replies.

Zoladex

Honorable
Apr 11, 2013
91
0
10,640
1
Hi

I mention first that I have already tried setting the Device Installation Settings to no, but Win10 still auto installs...

I'm trying to install Realtek HD Audio driver, but it's stuck in an install loop. The new driver uninstalls Realtek(R) Audio then asks to reboot the system. However on rebooting, windows jumps in first seeing there is no audio driver and installs an old Realtek(r) not the new HD.
I have tried uninstalling in Device Manager and ticking the delete software button. However, even just scanning for hardware changes puts the driver back on... Is there another option to stop windows auto installer?
Only other plausible bit I've seen in where you can manually update drivers. Unselecting the show compatible driver beings up 3 different Realtek drivers under the Microsoft tab. I have tried all of them but no avail :(

Any tips most welcome!
Cheers, Zola

(reason for install Realtek HD over Realtek, i which have control of where audio/mics to which speakers when i connect Aux/bluetooth speakers)
 

Darkbreeze

Titan
Moderator
Sorry that the images are broken. Tinypic closed down their free image hosting, breaking half the internet, just like Photobucket did a while back. Anyhow, the steps are still there until I get a chance to fix the images.

 

Zoladex

Honorable
Apr 11, 2013
91
0
10,640
1
Hi thanks for your reply. I was still having issue after setting Windows not to autoinstall. I managed to get the driver to install in safemode, however it didn't resolve :(

I believe i resolved it briefly earlier but it has reverted... After quite a bit of trial and error, Im sure i need set windows to pickup the heatset i plug into the computer as a 'Headset', which it i currently picking up as 'Headphone'

I believe this is the issue as i found Realtek Audio Console which opened software that looked like this.
View: https://www.youtube.com/watch?v=ScLzl05pVVc
. And it had setting in there that allowed me to do so, which worked for a little bit. However now Audio box says its not supported by windows...
I also think that what the guy does in the video will also help, but i dont know how to do that in windows. (Stop windows from muting audio devices)

Any ideas? :( let me know if im unclear, brain is little fried from all this ha
 
Last edited:

Zoladex

Honorable
Apr 11, 2013
91
0
10,640
1
RESOLVED.
Quite a headache, but have resolved using a whole number of fixes.

first, use Darkbreeze suggestion to stop autoupdate. (i had to include use of safemode in this step)
https://forums.tomshardware.com/faq/how-to-stop-windows-10-from-automatically-updating-device-drivers.2398360/

Then go to device manage and uninstall Realtek Driver, selecting the Delete the driver software box.
Find the latest driver you need and install it.

The final part was to re-enable Realtek Audio Console, which is not included with realtek driver... (and disabled due to the old version not being compatible with windows and does not self update) This can be found on the microsoft app store.
https://www.microsoft.com/en-gb/p/realtek-audio-control/9p2b8mcsvpln?rtc=1&activetab=pivot:overviewtab
Last part of this step is to make it so windows splits BOTH the audio & microphone sources to both computer speakers and headset.
Launch Realtek Audio Console and go to device advanced settings. Under connector retasking set it to Headset instead of Headphone. This will split the microphones.
Now to split audio, under playback device select 'make internal and external output devices.. ... stream simultaneously'


Woooooooooooooo, and with that time for a Tea :). Hope this helps someone.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS