Riviera + Z5500 woes

munk

Distinguished
Mar 6, 2005
4
0
18,510
Hey all!

I've been posting on various boards about this problem, but none has been able to give me any answeres, so hopefully someone on here can change that.

so i picked up a z5500 and a riviera card over the holidays. i'm having some troubles with getting the receiver to pick up the digital single.

i have sound and all, the card is connected to the receiver via optical cable. however, whenever i try to watch dvds, or play games. the receiver would still read stereo and stay in PL mode. no dolby digital for me =(

i've got my spdif enabled on my dvd player programs (media player 10, VLC)

i've read most of the stuff on the turtlebeach page, but still no dice.

i'm starting to thing i should switch over to the montego for the ddl.
anyway

thanks in advance!

Jason
 

astrallite

Distinguished
Sep 18, 2005
1,464
0
19,360
Try a Pro DVD player such as Deluxe versions of WinDVD or PowerDVD (and yes, we know you know where to get stuff like this...) and manually enable Dolby Digital 5.1.

Most of the free software players I've used seem to have inconsistent support of DD5.1 passthrough.

I'm not sure how DDL works, but I think it requires discrete analog channels...a pre-encoded DD source isn't gonna help you there.

Also, Dolby Stereo + Pro Logic 2 should come pretty close to Dolby Digital 5.1, since it's basically 5-channels downmixed to stereo, which is then re-expanded by PL2. The only thing that gets tossed out during the downmix is the ".1" subwoofer channel, but you still get bass from the mains routed to the subwoofer regardless.
 

munk

Distinguished
Mar 6, 2005
4
0
18,510
thanks for the reply! that's like the first, out of many other tech forums i've posted on.

oh i just figured if everything was coded into DD, it'd make everything simpler. lol.

anyway, i'll post an update after i give powerDVD a shot.

thanks again!
 

tonyh21

Distinguished
Dec 18, 2005
4
0
18,510
I had this problem too, AND I FIGURED IT OUT!!!!!!

In WMP10, go to options, dvd, advanced, speaker setup then you enable "connected to a reciever then check via a SPDIF cable and make sure you dont have ac3 filter installed.

THERE YOU GO, I finally figured it out, and a lot of owners of the Z5500 will be thrilled......

Tony