Question ROG B450-f gaming. GPU error light randomly on startup

Oct 25, 2019
3
0
10
0
I recently put together a build and when i power on the PC i will sometimes get GPU error (white light) and it wont post. ill power down and reset which will start to boot a safemode which takes me to BIOS. i exit BIOS with no changes and the PC posts with no problems. This doesn't happen everytime just sometimes. There are other times when i go to startup the PC and it has swapped my drive priorities from M.2 to SSD, since there is no OS on my SSD it gives me error that theres no OS installed and to restart which i then have to restart, go to BIOS, and swap boot priority back to M.2 then exit BIOS. again this all is just random chance on startup.

My current thought is to update BIOS but a second question i have in this thread is, Is it ok for me to update a BIOS that makes it Ryzen 3000 compatable even tho im using a Ryzen 7 2700x?

any info Helps thank you.

BUILD:
ROG Strix B450-f Gaming
Ryzen 7 2700x @ 3.7ghz
16gb EVOspear RAM @ 3000Mhz
MSI GTX 1080ti armor 11g OC
m.2 samsung 970 EVO plus
Toshiba SSD 500gb
EVGA 700 BR 80 Plus Bronze
 
Last edited:

cin19

Titan
Moderator
BUILD:
ROG Strix B450-f Gaming
Ryzen 7 2700x @ 3.7ghz
16gb EVOspear RAM @ 3000Mhz
MSI GTX 1080ti armor 11g OC
m.2 samsung 970 EVO plus
Toshiba SSD 500gb
EVGA 650W power supply
Can you check the PSU model? because you had the gtx1080ti, if the PSU is not good enough, you will get problem. The 650W does not tell you the whole story about the PSU, some of the EVGA 650W has problem to handle the gtx1080ti, even the gtx1070 too.
 
Oct 25, 2019
3
0
10
0
Can you check the PSU model? because you had the gtx1080ti, if the PSU is not good enough, you will get problem. The 650W does not tell you the whole story about the PSU, some of the EVGA 650W has problem to handle the gtx1080ti, even the gtx1070 too.
i will have to pull the PSU tomorrow to verify but would the PSU handles the build just fine when i have it up and running so it really wasnt on my mind as the problem. i run destiny 2 on ultra same with pubg with no problems its a start up issue. but like i said i will verify the PSU and follow up.
 
Oct 25, 2019
3
0
10
0
Ok cin19 the PSU im using is actually a EVGA 700 BR 80 plus bronze. so maybe it has something to do with the GPU error but it doesnt really explain why my boot drive priority keeps getting changed to the SSD without an OS instead of the M.2, which makes me startup in BIOS to select the M.2 and restart. im still thinking this might be a BIOS issue which brings me to the second question in my original post; can i update my BIOS to the latest version which supports Ryzen 3000 and still use my Ryzen7 2700x?
 

ASK THE COMMUNITY

TRENDING THREADS