Question ROG STRIX b450 f-gaming solid yellow kight

Dec 29, 2018
Hey all,

I have been having many computer issues lately.

But long story short I've replaced everything in my rig except for my PSU, RAM, and storage. (Parts list at the end).

The issue I've been having is that I can't even stream YouTube at 720p without insane amounts of stuttering. It is not my internet (I've got an Ethernet cable into my router and I've got 350 megabit download). And my CPU is at 100% utilization trying to stream YouTube or Netflix or anything like that.

I thought it was my CPU so I swapped my old ryzen 5 1400 for a ryzen 7 2700 just today. That didn't fix it so I grabbed this new MoBo which is the ROG STRIX B450 f-gaming. Still the same issue.

So I thought it was my ram which is Vengeance LPX 3000 MHz (2x8GB). So I tried taking one out at a time to see if there was a bad stick. When I took one out it booted up but still had the same issue.

So I put the second one in by itself and it won't post. So I put the first one in by itself again and it won't post.

I tried both again and it won't post.

It is just stuck on the solid yellow light when trying to boot up.

At this point I think I need to replace my RAM as well. Any ideas?
  • CPU: Ryzen 7 2700
  • Mobo: ROG STRIX B450-F Gaming
  • Memory: Vengeance LPX 3000 MHz (2 x 8 GB)
  • PSU: Corsair CX 650
  • Storage: 500 GB Samsung 860 EVO
Jul 30, 2019
Might have a solution for you on the no post. I got my Strix B450F mobo yesterday with 2x8gb Corsair Vengeance Pro 3200 ram and Ryzen 5 3600.
All installed, no post with yellow light.
What I did to fix it:
  1. Unplug PC and clear CMOS - Short the jumper that says CLRTC at the bottom of the board for about 5-10 seconds.
  2. Move your ram to slots A2 and B2 instead of A1 and B1, seems to be some weird compatibility issue between Ryzen and Corsair. Plug PC back in and power up.
  3. Your PC should post now. However the ram will default to 2133. In the BIOS set AI Overclock Tuner to D.O.C.P standard (this just sets things to optimal settings, memory freq to 3000mhz (in your case, when you set the AI Overclock it should default to this, just double check) and DRAM voltage to 1.35V.
  4. Save and restart
Hope this helps. Took me a good few hours to figure out but now my PC's flying!