ROG Strix X370-F Gaming AMD X370 Boot Issue: Yellow DRAM LED

Dec 2, 2018
1
0
10
0
Hello all,

I have just finished installing a new build (this is my first time building a system) with the following components:

-CPU: AMD Ryzen 7 Eight Core 2700X 4.35GHz (Socket AM4)
-Memory: Team Group Dark T-Force 16GB (2x8GB) DDR4 PC4-25600C16 3200MHz Dual Channel Kit
-Motherboard: Asus ROG Strix X370-F Gaming AMD X370 (Socket AM4) DDR4 ATX
-GPU: Asus Radeon RX VEGA 56 ROG Strix OC 8GB HBM2 PCI-Express Graphics Card
-Power Supply: EVGA SuperNOVA 750 G3, 80 Plus Gold 750W, Fully Modular, 220-G3-0750-X3
-Storage: TeamGroup 480GB L5 Lite SSD 2.5" SATA 6Gbps 3D NAND Solid State Drive
-Storage: WD 1TB Blue 7200rpm 64MB Cache Internal Hard Drive (WD10EZEX)
-Case: Fractal Design FD-CA-MESH-C-BKO-TG Meshify C Tempered Glass ATX/mATX/ITX Black

After first boot and during the POST the DRAM-Led on the mobo is always on in orange/yellow color indicating an issue with the RAM.

Everything else seems to be working OK. .. mobo RGB, CPU RGB cooler, fans, GPU RGB, the monitor flickers on for a second but then goes into power save.

I have used the recommended memory configurations from the manual: DIMM_A2 & DIMM_B2 (from left to right).

Important to clarify that the motherboard has the sticker "AMD Ryzen Desktop 2000 Ready" on the box thus I assume it can handle the Ryzen 7, 2700x CPU without any need to update the BIOS-software.

To verify that there is not issue with the GPU I have connected my monitor on the onboard HDMI port but still no signal.

Any help is much appreciated.

Thanks
 
Double and triple check all connections...especially memory seating.

Try one DIMM at a time to rule out defective memory.

It should support a 2700X since it has the sticker.

Don't bother connecting monitor to the motherboard HDMI ports as they will only work with an APU (2200G or 2400G).
 

ASK THE COMMUNITY

TRENDING THREADS