Question ROG STRIX Z370-E Gaming - Adding 4 port USB front bay hub

Mar 3, 2019
2
0
10
Hi,

Im trying to add a front bay 4 Port Hub USB 3.0 with Fast Charging Port, 19 Pin USB Header to my computer. I’ve installed it and when I plug in my USB device (external hard drive) the power light comes on but the drive does not get recognized by my computer. I’ve tried several other USB devices such as flash drives, phone chargers, optical mouse and keyboard….none get recognized. My device manager appears to show the device controllers It shows AS Media USB3.1 eXtensible Host Controller (x2) and Intel USB 3.0 eXtensible Host Controller (I may be wrong because quite a few USB devices and controllers show) I checked my BIOS and all USB are enabled, i have tried manually adding drivers for the hub and on install it tells me more up to date drivers are already installed. I can’t get the card to show.
The USB connectors on the back of the motherboard work as do the USB that are part of the case itself. The front bay USB hub that I am using is connected to the board with a blue 20 pin connector (1 pin is blocked so 19) Ive tried this hub on a different computer works so I ruled out a faulty hub.

Specs:
Rog Strix Z370-E Gaming
Bios V1802 x64
Intel I7 8700k, not overclocked
G.SKILL Ripjaws V Series 32GB (4 x 8GB) 288-Pin DDR4 SDRAM DDR4 2666 (PC4 21300
SAMSUNG E 500GB 970EVO NVME M.2 SSD
ASUS GTX1080A STRIX 8GB PCIE
PSU EVGA Supernova 750 G+ 750w Gold
CORSAIR CARBIDE SERIES 300R CASE
IPSG LG 24X DVD
IOCrest SY-HUB20134 3.5 inch 4 port USB 3.0 bay hub
MS OEM WINDOWS10 HOME 64BIT COEM Windows 10 is Version 1809 (OS Build 17763.348)

Drivers
• VGA Version 25.20.100.6471 2019/01/24
• Audio Version 6.0.1.8480 7/25/18
• LAN Version 12.18.8.4 2019/01/24
• Chipset Version 1828.12.0.1152 2019/01/24
• SATA Version 17.0.1.1075 2019/01/24
• Video GeForce Game Ready Driver Version 419.17 release 2/22/19
• Windows 10 all updates discovered and current

Steps ive tried so far:
• Made sure all MOBO drivers are up to date
• Ran ez flash and updated BIOS
• Checked BIOS under USB settings and all were enable

I know this is a lot of info, I just wanted to make sure I added any info you may need .

I guess my main questions are:
• Does this motherboard support more USBs? I assumed so since there are connectors on the board for more
• Am I trying to add too many? Mother other computer has more USBs (2 PCIe cards as well as a front bay hub)
• Any suggestions to try to get this to work?

Ty for your time
 
Last edited:

ASK THE COMMUNITY