Question ROG Strix Z370-H, no video after 64GB RAM upgrade?

escobarpc

Honorable
Aug 7, 2014
7
0
10,510
0
Hello everyone,

Today I picked up an extra 32GB of RAM to add to my existing rig. After installation, I’m not getting any beeps, my rig powers on but I get no video display, noticed the mobo light stays yellow/orange after boot.

When I remove the extra ram (2x16) it boots up fine. I saw that I had an updated BIOS firmware version so I went ahead and updated it to the latest (included ram fixes). However, this didn’t help me much, I am still getting the same issue of basically no video but everything is powered on.

Motherboard: Asus ROG Strix Z370-H on latest BIOS firmware.
RAM: G.skill Rip Jaws DDR4 3200 (16x4) = 64GB
CPU: i7-8700k

Anyone else face this type of issue? RAM was purchased from a Microcenter new, possible I got some bad RAM? Any recommendations?
 
Last edited:

escobarpc

Honorable
Aug 7, 2014
7
0
10,510
0
Update! Just got off the chat with Asus support. Apparently the issue is due to my RAM sticks selling as 2 as opposed to it being individual RAM.

Thank you for patiently waiting! Based on our information here, your RAM stick are listed on the QVL for memory of your motherboard, However, the RAM stick has limited capability where they will only going to work with just 2 stick of RAM,

Indeed the motherboard supports 4 RAM sticks at a time, but you need to use a RAM stick which is purchased as a single stick, meaning, both 4 ram stick came in just one box not 2 stick per box.

You can check the QVL for memory of the board using this link : https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/ROG_STRIX_Z370-H_GAMING/Z370-H-DRAM-QVL-0413.pdf?_ga=2.178114085.100652713.1582381232-1369258399.1582043921
https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/ROG_STRIX_Z370-H_GAMING/Z370-H-DRAM-QVL-0413.pdf?_ga=2.178114085.100652713.1582381232-1369258399.1582043921
 

ASK THE COMMUNITY

TRENDING THREADS