Question ROG Strix Z690A Gaming WiFi WHEA 17 Errors w/Alder Lake and RTX 30XX

Dec 1, 2021
5
0
10
0
Swapped my fully functioning 3090RTX, 9900K, Z390 Gigabyte Designare setup for a brand new Z690 and 12900K rig.

After swapping all components over to the Gaming Wifi MOBO and 12900k combo, install WIN 11 and I get thousands of WHEA errors for ven_8086&dev_ 460d&SUBSYS_86941043&REV_02

I also get random hangup, BSODS, and straight crashes.

Fresh WIN 11 install, updated bios for ASUS Z690-A Gaming WIFI MOBO, 12900K, ASUS TUF OC 3090 GPU, Samsung 970 PLUS as Boot Drive in M.1 slot, and a Samsung 970 PLUS in 2nd M.1 slot.

Others experiencing the same thing. Only solution so far is putting GPU in 2nd PCI slot running at GEN 3 speeds (kinda beats the point of having a GEN 4 card). At this point I'm guessing this devolves into finger pointing between Intel and Motherboard manufacturers in regards to whose drivers are broke for this....insert Spiderman meme.

Someone with a similar issue here: https://community.intel.com/t5/Processors/WHEA-LOGGER-ID17-help/m-p/1328866#M54659

https://www.reddit.com/r/ASUSROG/comments/r35jsw View: https://www.reddit.com/r/ASUSROG/comments/r35jsw/rog_strix_z690a_gaming_wifi_whea_17_error/

and
https://www.reddit.com/r/gigabyte/comments/r0wa1o View: https://www.reddit.com/r/gigabyte/comments/r0wa1o/z690i_aorus_ultra_ddr4_pcie_whea_errors/


I’ve tried the following:

  • disabling PCI-E link power state management seems to reduce the amount of WHEA's, but it still crashes under heavy load
  • Next, I removed the GPU and ran the system off of the iGPU. No crashes, no WHEA's, running prime95 and cinebench without any freezing whatsoever.
  • Next, I set the top PCIE slot at gen 3 in bios – same issue persists.
  • Finally, plugging the GPU in the lower PCI-E slot works fine without issues. But now my ASUS 3090 TUF OC is running at PCIE 3 and lower bandwidth – this is a bandaid and not a fix.
Problem seems isolated to the top PCI-E slot. I tried reseating the card and still had the issue. Problem persists using a riser cable or direct plug in. Also, problem exists for many different people.

When I swap all components back to my backup computer (Z390 Gigabyte Designare, 9900K CPU) I have zero issues and full performance.

Event Viewer shows the following details

A corrected hardware error has occurred.

Component: PCI Express Root Port
Error Source: Advanced Error Reporting (PCI Express)

Primary Bus:Device:Function: 0x0:0x1:0x0
Secondary Bus:Device:Function: 0x0:0x0:0x0
Primary Device Name:pCI\VEN_8086&DEV_460D&SUBSYS_86941043&REV_02
Secondary Device Name:



Any ideas on solution?
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Can you state where you sourced the installer for the OS? BIOS version for your motherboard after the update? As for your specs, please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:

mentioning a before and after as you're state performing an upgrade on parts(the system). Age of the PSU in the build? Firmware on the SSD's up to date using Samsung's Magician app?
 
Dec 1, 2021
5
0
10
0
Installer was via media creation windows utility off 8GB USB.

Product Model ; S/N: ROG STRIX Z690-A GAMING WIFI D4 BIOS 0707 (serial M9M0KS1641905L8; part 90MB18K0-MVAAY0)
BIOS/FW Version Updated to 0707 (but also occurs on original bios out of box)
CPU: I9-12900K
Memory: Corsair Vengeance RGB PRO (2x16GB) DDR4 DRAM 3200MHz C16 Desktop Memory Kit - Black (CMH32GX4M2E3200C16)
HDD: Samsung 970 PRO (1TB) in first M2 spot; Samsung 970 PRO (2TB) in 2 nd M2 Spot
VGA: 3090 TUF OC Gaming
Power Supply: Main Gear Ignition 1000 Watt
 
Dec 1, 2021
5
0
10
0
Fixed. I had to disable native power management and ASPM in BIOS. Then I had to disable link state power management in power settings on desktop.
GPU is now running as it should on GEN 4 with no errors.
 
Dec 1, 2021
5
0
10
0
Update: nope, getting new crashes and artifacts with those settings disabled even though the WHEA 17 error went away.

I put all those settings back for ASPM and Native Power Management. Now back to running at PCIE 3 no errors.

Only thing that works to rid of WHEA 17 error is putting it to gen 3 or turning off native power management. ASPM has no impact on the WHEA 17 error, only Native Power Management turned to disabled. However, turning off native power management in BIOS results in artifacting and lower gpu performance...absolutely crushes GPU performance in 3dmark.

Very frustrating.

Trying MSI board tomorrow.
 

theboeingman

Distinguished
Dec 5, 2012
20
2
18,515
0
I am using Asus ROG Z690-A D4 and 12900K with the same problems as yours. I've traced the issue down to poor BIOS. I've tried all BIOS revisions and the newer releases seem to exacerbate RAM instability despite Asus claiming in their changelog they've improved it. I've gone back to the original BIOS rev1 released back in July 2021 which is the most stable.
 
Jan 15, 2022
1
0
10
0
Hi. I bought ASUS ROG STRIX Z690-A GAMING WIFI D4 LGA1700 Motherboard and it cannot detect my 3060ti or my old gfx 970. only the onboard GPU from MB is working. i tried to change cpu gpu to pcie in System Agent Configuration but it goes back to cpu gpu after saving and reset. I tried updating bios to latest but same thing happen. Anyone can help please?
 

ASK THE COMMUNITY

TRENDING THREADS