Ephx87

Distinguished
Nov 30, 2011
12
0
18,510
0
Hi guys, just finished putting together a new system for a friend. Asus ROG z390-f, i7 9700k, 16gb corsair vengeance rgb, msi rtx 2070 super, nzxt kraken cooler, nzxt h700i case, 128gb intel nvme, 2tb mech drive powered by a corsair rm750x with cablemod modular sleeved extensions. Also using nzxt AER rgb 2 fans into a hue 2 controller. Upon assembly discovered that i am short 1 usb2.0 header on the board so have left the h700i’s pre-installed hue+ controller disconnected and connected the kraken aio & hue 2 controller. The issue is after assembling the whole build upon powering on everything seems to light up as expected (gpu rgb lighting, fans all light up and all spinning, kraken lights up, motherboard RGB panel lights up, rgb ram lights up) but there is no signal on display from either displayport or hdmi outputs. Have tried 3 different displays trying both hdmi and displayport outputs on the graphics card and then on onboard all with the same result. All of the rans go straight to 100% upon powering on leading me to believe that the system is not posting (there is no speaker with the rog Z390-F but there are leds on the board to indicate faults). None of the fault indicator leds light on the motherboard at all at any time but yet the rog led lighting on the motherboard lights up / transitions between colours. Have to long press the power button to turn the machine off.

Have tried disconnecting both the aio cooler and the hue 2 controller from their usb2 headers and the result is the same. Has anyone encountered anything similar to this when building on z390-f? If so what did the problem turn out to be? And is there any advice you would recommend?

Thanks
 

jimmysmitty

Polypheme
Moderator
First step is to check and make sure there are no shorts caused by standoffs from the motherboard tray. Most manufactures have standoffs preinstalled and I have, a time or two, missed one when putting a certain board in that doesn't need them in certain places.

Next would be to eliminate the parts one by one. I would start by removing the GPU and using the onboard GPU to see if it posts. Then try each stick of RAM itself. If that doesn't work try using the original power cables to make sure nothing is wrong with the after market cables.

If all else fails, pull everything out and put it on a test setup outside of the case and see if it works that way.
 

ASK THE COMMUNITY