Roll-back drivers

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
I have catalyst 3.10, and to go back to, say, 3.5, do I just go through normal install procedures for 3.5? Or do I unistall 3.10, then install 3.5?

Anxiously awaiting prescott....is it here yet?
 
Usually going from previous to latest drivers you can simply install over them, however I've found going backwards harder, but not too complex. You do need to uninstall the latest ones though in my experience.

The quickest way to remove drivers is to go to add/remove in the contol panel, and select the "ATI software uninstall utility", then add the 3.5s. You can also go into the add/remove and remove the drivers and control panel.

Upon reboot cancel(or X out) all the Windows hardware recognition stuff. Then install the driver pack (which you should have loaded before starting all this of course).

Be sure to add the associated control panel with 3.5 to ensure compatibility. Also moake sure you card is supported. May not cause you problems, but could.

For a more thorough job, use a driver-cleaner program, then install new drivers. Check out this thread at R3D, explains a thorough way;
<A HREF="http://www.rage3d.com/board/showthread.php?s=&threadid=33656771" target="_new">http://www.rage3d.com/board/showthread.php?s=&threadid=33656771</A>

Hope that helps.


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
Thanks, ive just been having some problems with my new 9600 pro, and I think it may be driver issues.

Anxiously awaiting prescott....is it here yet?
 
Good luck. What problems? I've got an R9600Pro. You can check the Catalyst review and see if it's Fastwrites maybe. Just a thought.

Maybe if you described the problem people could help you solve it, but try the new drivers and let us know.

Gotta Sleeep! So tired, too much drinking and smoking (La Flora Dominica and Romeo Y Julietta) today watching hockey.

Anywhoo, you might want to check with the Rage3D Forums as well to see if there's a similar issue someone is dealing with there.


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
Well, I already posted this in a thread, but here it is again. In Madden NFL 2004, online, whenever I click on the messenger, the tab just disappears and no messenger comes up. To really see that this is a relatively large problem, you have to play Madden online, it doesnt seem that big if you havent played it. All of the other menu's and stuff works fine. When I had my GeForce 2 MX, all worked well. I've tried reinstalling the game, and I have tried just installing various versions of catalyst. I got to go to bed too, and I got some stuff that I need to do tomarrow, but when I get a chance, I'll try your suggestion and see if it works, then post my results.

Anxiously awaiting prescott....is it here yet?
 

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
When you say select the "ATI software uninstall utility", does that mean uninstall the "ATI software uninstall utility"? Don't I just want to run that?

Anxiously awaiting prescott....is it here yet?
 
Click on it (remove) in the ADD/Remove programs list and it will start the uninstaller.

'Nite.

- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
Removed old drivers, installed 3.6. Same prob :(. I'm really starting to warm up to a 5700 ultra right now...

Anxiously awaiting prescott....is it here yet?
 

bandikoot

Distinguished
Apr 23, 2003
423
0
18,780
Why 3.6? I figured you pulled out 3.5 because those were the ones officially supported by EA when the game came out. While I haven't played Madden online, I'm assuming it works like blizzard where you have to get the latest patch when you play so you should be up to date with those...
 
It may be a known issue. I would try RAGE3D.com 's forums. They may have something on it, there may already be a fix of some kind. If it doesn't work, and you can, sure try the FX series, the main thing is to get your games to work.

I know EA does have an annoying habit of having nv-contric features (kept me from buying NHL2004 our of protest [sent e-mail explaining it too], I've had every one since NHL96), but I doubt this would be it, it's usually things like effects and such, not bugs, but it could be an effect that causes a bug. Check the EA and Rage forums, they would likely already have something if this is a common problem. Who knows could be somthing else even.

Let us know if you find a solution/comond thread to this.

Good Luck!


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
The card is OC'd, but since there are no other problems I doubt it would be the problem, would it?

Anxiously awaiting prescott....is it here yet?
 
First for your CAT version, check your advanced features in you Display control panel, and check the Adapter Tab, it should show you the Catalyst version.

As for OC'ing, ALWAYS run a game through STOCK to see if a problem goes away. I doubt it's that, but when trouble shooting you set EVERYTHING to DEFAULT, and then check one thing at a time. Set your FSB to stock, your, VPU/MEMROY to stock, same with all other settings. Then see if it still happens.
I would also roll back Further if you were going to go back. Try the 3.4 or 3.2 drivers. The Major leaps are 3.2, 3.4, 3.5, 3.7 (3.6 wasn't officially 'released' it was skipped, 3.8, 3.10.

I would suggest 3.4 and 3.2, but I doubt even that will fix it. The best thing to do is to check the EA and Rage forums. Seriously I doubt you're the only person to experience this if it's not something you've tweaked.


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
I installed 3.5 because that is what Madden officially supports, so do i really need to go back farther? I cant post in any forums really because my e-mail is messed up do to a recent switch to DSL...I really love computers... :(

EDIT-I did post it in the EA forums, hopefully I will get a reply...

Anxiously awaiting prescott....is it here yet?<P ID="edit"><FONT SIZE=-1><EM>Edited by gobeavers on 01/19/04 00:45 AM.</EM></FONT></P>
 
Well you don't have to post, just search and see if someone has already posted a related issue. If 3.5 was the first official support, then yes rolling backto just that is good, going further isn't worth it unless you are just curious. I'm surprised. If it's officially mentioned, then I have a feeling it's not so much the driver as the combination of things. I just 'fixed' the FastWrites issue for me w/ Catalyst drivers above 3.5 by updating the mobo BIOS. Well why should I need to do that, everything worked FINE before.
Anywhoo, it's amazing all the things that can go wrong, as I see you've found out with your ADSL issues :wink: .

I would suggest searching the forums even if you're not posting. Hopefully your post in EA's forums will get you some good results. Were kinda flying blind here. I only play Madden on a friend's PS2 when a whole bunch of us get together to watch Football or Hockey. I only play NHL 2003/2002/2001 (and 98 on my Laptop), F1 2002, and Rugby 2001.


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
Well, thanks for all your help. I may just fork over 200 bucks, get a 5700 ultra, put this 9600 pro into my 220 watt mini pc, and if the ultra doesnt work, break down and cry.

EDIT- Just looked at 5700 ultra benchmarks, and it doesnt make my decision any easier. I will be playing DX9 games and I hate buying a card worse than what I already have for it...
Anxiously awaiting prescott....is it here yet?<P ID="edit"><FONT SIZE=-1><EM>Edited by gobeavers on 01/19/04 03:11 AM.</EM></FONT></P>
 
Se if you can find an FX5900SE then. That would give you much better performance for about the same price as an FX5700U.

But check and see what you can find out, there may be a work around out there or something you missed.


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

gobeavers

Distinguished
Jun 7, 2003
446
0
18,780
Hey, thanks for the great suggestion. The 5900 SE card looks great, and the price is right at the 5700 ultra too. I just may buy it.

Anxiously awaiting prescott....is it here yet?