Question RPi-4B boots to solid pink screen with Desktop editions of RPi-OS, but not with Lite ?

Feb 16, 2021
2
0
10
0
I am using RPi-4B and experiencing problems when booting into RPi-OS Desktop editions but no problems when booting into RPi-OS Lite. My original suspicion was I had received an electrical surge through the POE connection, but after acquiring a new RPi-4B and SD card I powered up the new RPi-4B with only the HDMI and power cable and got the same result! Please see details below.

I have posted on the Raspberry Pi Forums, but after about a week and 59 reads there have been no replies. I am providing below a copy of my original thread in hope to get information that can help me resolve the issue I am experiencing with booting a new RPi-4B in to desktop versions of RPi-OS and getting a pink screen instead of the desktop image.

I apologize if this thread is a bit too long for some.

Copy Of Original Thread:
I have an RPi4B 4GB running RPi-OS standard desktop and Node-Red. This rig also boots from a 1TB WD Passport Drive, has the RPi POE HAT and the RPi 12MP camera with three GPIO pins connected to a dry relay switch on a P32 Inductance Loop Detector. This rig takes a photo every time a vehicle passes over the induction loop buried in the asphalt driveway. This rig is headless and I monitor using a cloud based remote agent software on the RPi-4B.

I noticed the rig went off-line earlier this week. I power cycled the POE connection and saw normal LED boot activity on the RPi-4B but the rig never appeared on the network. I took the unit to the bench for a more detailed inspection. After removing everything from the RPi4B board I added my backup SD card and HDMI to a monitor. I then powered on the RPi4B and got the same proper activity lights but when I expected the desktop I got a pink screen. My initial thought (always the worst) was a surge got into my wires and a surge fried my RPi4.

I began trying other SD cards on the bench to rule out a bad SD card and all were failing with a Pink screen except one RetroPie SD card I had created a few weeks ago. I was encouraged and decided to get a fresh SD card get a fresh download of RPi-OS Desktop Only and test...got Pink screen when the Desktop should appear! I then downloaded a fresh copy of RPi-OS Lite and test...PASS! All command line functions work properly. At tis point I am now thinking there is something damaged in the video portion of the RPi4B.

In an effort to get my photo rig for the loop detector up and running I grabbed another RPi4B (the one I use for Retropie) and proceeded to build a new photo rig, but with the RPi4B board only. No POE Hat, no USB boot. Once I had RPi-OS Desktop and Node Red configured I then started adding the other components beginning with the POE HAT. After adding the POE HAT and connecting to my POE Switch to this tested rig the Pink Screen returned when the Desktop should have appeared! This is the same POE HAT that was on the original photo rig!

I removed everything from this second RPi4b and performed the same testing procedures as on the first RPi4B and got the same result. Both RPi4B boards boot just fine using RPi OS Lite, but produce a solid pink screen when a desktop OS is loaded. This is why I now suspect possibly a network surge, even though the Cisco POE switch is running all other equipment without faults. Even the port that was originally used by the photo rig.

I look forward to any discussion offered on this topic. I have never experienced such a problem with a Raspberry Pi.

Thank you for your time.

Update:

I have purchased two new RPi-4B units to insure no hardware defects. I have also purchased new Sandisk Ultra Plus 16GB SD card and loaded the latest RPi-OS Desktop dated January 11, 2021.

When I connect the new RPi-4B to HDMI and power, on the boot process begins and normal activity light flash when loading the OS. All of the normal rainbow and flash screens appear during boot process. At the point when the desktop should appear I get a solid pink screen.

I replaced the RPi-OS Desktop with RPi-OS Lite dated January 11, 2021 and power on, the boot process begins and normal activity light flash when loading the OS and a normal appears with the command prompt and login is successful. I do not experience any problems with RPi-OS Lite on any of my RPi-4B units.

I no longer believe there was an electrical surge that is causing the symptoms I am experiencing. If RPi-OS Lite loads and the RPi-4B runs properly then the hardware should be OK. It is only when I try to load an RPi-OS with a graphical interface that I am getting the pink screen, even on a new RPi-4B and new SD card with fresh load of the RPi-OS Desktop and nothing connected to the RPi-4B except SD card, HDMI, & power.

I am looking for anyone that knows of a diagnostic process for this strange problem I am having with loading Desktop versions of RPi-OS desktop and getting a pink screen instead of proper desktop on a new 'out-of-box' RPi-4B?

I look forward to any input that can point me in the right direction to solve this problem.
 

ASK THE COMMUNITY