Question RTX 2060 laptop - very low GPU usage on everything

tuffluck

Distinguished
Oct 2, 2009
312
0
18,810
I have a 3 year old Sager laptop with a 9th gen i7 7950H CPU and a 2060 RTX GPU. I really only played Warzone 1.0 and it worked just fine for me with 90FPS on pretty high settings. Once I installed Warzone 2.0 I've had nothing but problems. I usually get around 50% CPU usage and 10% GPU usage, even on low settings. I also don't do the 90FPS on Warzone 1.0 anymore, either. I even tried Timespy 3d Mark and my scores are terrible and once again I'm seeing GPU usage under 10% and CPU usage only about 30%.

I'm not sure if my GPU is just going bad or if somewhere along the way some setting got changed. I tried uninstalling GPU drivers but that didn't do anything. Any idea what could be going on or what I should attempt to do to fix this issue? It doesn't seem to be game specific rather an overall system issue entirely. Other than gaming, the PC itself runs just fine. Thanks.
 

Lutfij

Titan
Moderator
First, check and see if the laptop has any BIOS updates pending. Following that, check to see if the OS has any updates, following that, use DDU to uninstall all GPU drivers off of your platform, then manually reinstall the latest GOU driver off of Nvidia's support site in an elevated command, i.e, Right click installer>Run as Administrator.
 

tuffluck

Distinguished
Oct 2, 2009
312
0
18,810
as it turns out my integrated graphics was the only card running. i auto set everything in nvidia control panel to use my rtx2060 and right away things were better. now i see about 75% usage on both the CPU and GPU, which still doesn't seem optimal, but i'm getting 40-60fps in game with DLSS on and relatively above average settings on warzone 2.

i still think something is wonky but i haven't figure out what. i don't know how my laptop defaulted to integrated graphics recently even though it was showing in nvidia it was using high end graphics for this game. but apparently it was using integrated graphics for everything.