Question RTX 2060 not working as expected

Nov 3, 2022
Upgraded from a GTX 970 to a new RTX 2060 about 2 weeks ago. Worked completely fine for the past 2 weeks, then 2 days ago suddenly things went wrong. I have 4 sticks of 8GB ram at 3200hz, and a i5 10400f.
I did not change any settings whatsoever, but there was a sudden loss in performance. Apex Legends at 1080p low graphics used to run at a consistent 144fps (capped), and now it struggles to achieve 60. Other games have also suffered similar amounts of FPS loss, except for League of Legends, which does not seem to have any performance issues.

On task manager, the 3D usage is at 100%, however the GPU temperature does not rise above 50, even during gaming. The dedicated memory usage flatlines at 4GB out of 6GB. I have tried updating drivers as well as pulling back to older versions that I have been using in the last 2 weeks. I have enabled resize bar options in the BIOS, and turned off iGPU recognition as well. Please can anybody help me?

I still have 2 weeks left to return this GPU but I would prefer it if it would start working again.

EDIT: installed GPU z, and ive noticed that my board power draw is at a constant 116 watts, and the 8-pin #1 power is consistently at 18 watts even when gaming. Is the PSU not supplying enough power? I've tried installing my previous GPU back in after I noticed problems with the new one, but that one seemed to have no issues whatsoever and was performing better than the new 2060.
Last edited: