Question RTX 2070 - Low FPS

Aug 21, 2019
3
0
10
0
Hey,

I need some help with my self-built PC. Everything seems to be in order according to MSI Afterburner (Freq, Temps, etc.), but my Benchmarks don't reflect that at all (eg. Rise of the Tomb Raider averages at around 20 FPS on Ultra Settings at 4K Resolution).

Specs are as follows:
GPU: RTX 2070 STRIX Gaming OC
CPU: Ryzen 5 2600x
MB: MSI B450 Tomahawk
Memory: 16Gb DDR4 3200MHz
PSU: be quiet! Pure Power 10 600W
 
Aug 21, 2019
3
0
10
0
Thanks, I updated my drivers again and it got a bit better, FPS averages at around 45 now. Still not as high as I expected.

Isn't Rise of the Tomb Raider already 4 years old? Shouldn't an RTX 2070 be able to run it smoothly on highest settings?

GPU Temp usually doesn't go above 65° and CPU maxes out at 94° doing the Heaven Benchmark.
 
Something is wrong with your cooler, make sure it is seated properly on the IHS.. Your CPU should not be hitting 94C in heaven. Ryzen throttles at 95C, so you CPU is probably throttling to keep temps below 95C to prevent damage. When the CPU throttles, clocks go downa and frame rates plummet.
 
Reactions: Metal Messiah.

James9002uk

Commendable
May 30, 2017
33
1
1,535
0
At 4K at High/Ultra yes you would be getting 20FPS.

Need to optimise the in-game settings, and not just use the standard pre-set - sorry!

For example, turn down shadows, AA - super sampling off as you don't need it at the resolution... check out some YouTube videos...

Also do you have a second monitor?

Check if you're in full-screen VS windowed mode - this can affect FPS...
 

Ketchup79

Upstanding
Aug 7, 2019
450
44
240
6
Is that the stock AMD fan? Are you overclocking the CPU? You aren't the first person I have seen posting high temps on these Ryzens. Not sure if the app you are using is giving you wrong temps (what app for CPU temps?), or the fan they come with is really that inadequate.

Also, just because a game is a few years old, doesn't automatically mean you can run it at the highest visual settings, as James stated above.
 
Aug 21, 2019
3
0
10
0
Thanks for the quick replies. I'm going to try reinstalling the cooler and if I don't cry for help again, that will have done the trick.
 

ASK THE COMMUNITY