[SOLVED] RTX 2070 Super Displayport Disconnecting

Status
Not open for further replies.

CDDogg

Honorable
Aug 20, 2015
252
3
10,815
18
So back in August 2020 I purchased an RTX 2070 Super. It worked really well in my build at the time, and has always been able to drive my monitors + HTC Vive without issues. In January of this year, I built an entirely new machine, and used the same card. The specs are:

AMD Ryzen 9 3950X
ASRock B550M Steel Legend
Cooler Master MA620M
Seagate FireCuda 520 M.2 2280 1TB PCIe Gen4
2x16 GB TridentZ RGB DDR4 3200
ZOTAC RTX 2070 Super
SanDisk Ultra II 1TB Sata SSD
an old unknown 7200 500GB HDD
CORSAIR CX750F

This build worked flawlessly for months. Then I started having issues with my monitor connected via displayport. Whenever the GPU was under load, not even near 100%, but just above idle, the monitor would disconnect for a couple seconds, and then fire back up. I initially thought it could be a driver problem, or a cable issue, or even the monitor itself. But then it started happening with my Vive as well. For most VR gameplay, everything is just fine, until something particularly heavy needs to be rendered, and then my Vive displays will go black, and I'll lose sound for a few seconds. Then it'll fire back up and continue working fine.

Could this be an issue with my GPU or my Power Supply? Other than these problems, nothing else is wrong. I've seen no errors in any logs or event viewer, and it seems to happen completely arbitrarily, there's nothing I can do specifically to trigger it. I'm pretty sure a 750 should be enough to handle what I'm running, and as I mentioned it's only the DisplayPort connections. My monitors running off of HDMI are just fine.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS