[SOLVED] RTX 2070 super low usage in game.

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
A few weeks ago I bought a new desktop. It came with a faulty HDD so as of right now I'm playing games on my ssd.

Last week I was playing Metro Exodus and it ran really well, but after a day or two the game started to get choppy and laggy. I opened task manager and noticed the game was using 0% of my GPU. As I already had finished the game I uninstalled it and installed Battlefield 5. Again for the first day it was running perfectly, no stutters or anything. Now today I went to play and it was unplayable. Bad framerates, bad stutters every two seconds. I opened task manager and yet again it's using close to 0% of the gpu, it was constantly about 2-3% never more than that.

My specs are:
AMD Ryzen 7 3700x
Gigabyte RTX 2070 super Gaming OC
16GB Corsair Vengeance LPX 3600MHz Cl16
MSI B450 Gaming Pro Carbon Max Wifi
Corsair CX650M Semi Modular PSU

What might be causing this problem? I have it so on nvidias control panel it's set to max performance and both my monitors are connected to my graphics card not to my motherboard.

What might be causing this issue? It was running fine the first day I play a certain game then it stops working correctly...
 
Yes it is, but I managed to find out how to fix it. I had to use a tool provided by windows themselves. I'm currently installing drivers, and will soon reinstall battlefield and see it works fine. Though it worked fine the first time I played so I really can't be sure from the first hours
Good but I wouldn't install Geforce experience...just the NVidia driver.
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
"so as of right now I'm playing games on my ssd. "

Where did this SSD come from?
Did you do a clean Windows install on it?
I bought both an SSD and an HDD. Windows is installed on the SSD and, since my HDD is not working, I've installed a game or two on the SDD.

So I installed a clean version of windows on it since the drive was new
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
If you have that Geforce experience installed....I'd get rid of that....I've had issues with that and other have too. I just run the driver now.
I unninstalled Geforce Experienced, downloaded the newest driver from the site, installed it without instaling Geforce Experience, restarted the computer and it still the usage is around 3-5%, and the game is still uplayable :/
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
and I wouldn't use sleep mode because I've seen this happen when using sleep mode.

I did all of those things, checked PCIExpress but unfortunatly it didn't work.

I did run UserBenchmark's bencharkt tool and the GPU is running fine, so it has to be something software wise. I've tried to reinstall windows but it doesn't let met. Says something about introducing a suport data or something of the sort
 
I did all of those things, checked PCIExpress but unfortunatly it didn't work.

I did run UserBenchmark's bencharkt tool and the GPU is running fine, so it has to be something software wise. I've tried to reinstall windows but it doesn't let met. Says something about introducing a suport data or something of the sort
" I've tried to reinstall windows but it doesn't let me"
That is odd. Is it a legitimate copy?
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
" I've tried to reinstall windows but it doesn't let me"
That is odd. Is it a legitimate copy?
Yes it is, but I managed to find out how to fix it. I had to use a tool provided by windows themselves. I'm currently installing drivers, and will soon reinstall battlefield and see it works fine. Though it worked fine the first time I played so I really can't be sure from the first hours
 
Yes it is, but I managed to find out how to fix it. I had to use a tool provided by windows themselves. I'm currently installing drivers, and will soon reinstall battlefield and see it works fine. Though it worked fine the first time I played so I really can't be sure from the first hours
Good but I wouldn't install Geforce experience...just the NVidia driver.
 
Aug 3, 2020
8
0
10
0
Yo i just did a account here to reply to this.
Because Today my RTX 2070 also started to become SUPER slow in some games, with no GPU usage.
Turns out for some reason MHW and COD (only those games so far) use GPU - Copy instead of 3d. and my dwm.exe is running the game instead but with only a few (20 ish%), so its super laggy! i couldnt find a fix yet, so please tell me if reinstalling windows fixed it for you!
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
Yo i just did a account here to reply to this.
Because Today my RTX 2070 also started to become SUPER slow in some games, with no GPU usage.
Turns out for some reason MHW and COD (only those games so far) use GPU - Copy instead of 3d. and my dwm.exe is running the game instead but with only a few (20 ish%), so its super laggy! i couldnt find a fix yet, so please tell me if reinstalling windows fixed it for you!
I would unninstall Geforce Experience and see if it fixes it. If not, first thing in the morning I'll tell you. Through it might fix just for a day or two.
 
Reactions: Nechronica
Aug 3, 2020
8
0
10
0
I would unninstall Geforce Experience and see if it fixes it. If not, first thing in the morning I'll tell you. Through it might fix just for a day or two.
I have no geforce experience installed, i already cleared my drivers wiith DDU several times and tried different drivers, but nothing fixed it. Which is funny because yesterday i was streaming Cod with 150+ fps, and now because its stuck on Gpu - 0 Copy i barely get 60 frames.
i'll wait for your reply tomorrow in that case! i spend most of my day trying to fix this, and at this point reinstalling windows would've been faster.
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
I have no geforce experience installed, i already cleared my drivers wiith DDU several times and tried different drivers, but nothing fixed it. Which is funny because yesterday i was streaming Cod with 150+ fps, and now because its stuck on Gpu - 0 Copy i barely get 60 frames.
i'll wait for your reply tomorrow in that case! i spend most of my day trying to fix this, and at this point reinstalling windows would've been faster.

Just make sure to save important stuff. I was so eager to get this done that I forgot to back up a project I was working on. Other than that, I'll let you know if it's working or not. Might have been an overnight update to either Geforce experience or to windows, even though I had this problem with metro exodus.
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
Just make sure to save important stuff. I was so eager to get this done that I forgot to back up a project I was working on. Other than that, I'll let you know if it's working or not. Might have been an overnight update to either Geforce experience or to windows, even though I had this problem with metro exodus.
Ok so I don't even need to wait until morning to tell you. Right now it is fixed! Solid FPS on BF5, I had to use the in game's fps counter as I haven't installed Geforce Experience!
 
Aug 3, 2020
8
0
10
0
Ok so I don't even need to wait until morning to tell you. Right now it is fixed! Solid FPS on BF5, I had to use the in game's fps counter as I haven't installed Geforce Experience!
Thats good news! Do you know if your Gpu engine showed Copy too instead of 3d before you reinstalled windows? Because thats my issue, and that causes the game for me to not use my gpu at all
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
Thats good news! Do you know if your Gpu engine showed Copy too instead of 3d before you reinstalled windows? Because thats my issue, and that causes the game for me to not use my gpu at all
Unfortunately I didn't notice that part before I installed a fresh windows. I would save everything that is important and I would reinstall windows. Be sure to install all the drivers your computer needs and install the latest Nvidia driver from their website without downloading GeForce Experience. I hope it also fixes your problem as I know it is very infuriating.
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
Unfortunately I didn't notice that part before I installed a fresh windows. I would save everything that is important and I would reinstall windows. Be sure to install all the drivers your computer needs and install the latest Nvidia driver from their website without downloading GeForce Experience. I hope it also fixes your problem as I know it is very infuriating.
Nevermind, I just went to play again and had the same issue, it did not fix it ://
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
Thats good news! Do you know if your Gpu engine showed Copy too instead of 3d before you reinstalled windows? Because thats my issue, and that causes the game for me to not use my gpu at all
Good news again, found the issue, it's DirectX12. That's what's lagging my games. So you might wanna check if you had DX12 enabled
 
Aug 3, 2020
8
0
10
0
Good news again, found the issue, it's DirectX12. That's what's lagging my games. So you might wanna check if you had DX12 enabled
reinstalled windows, my game ran for about 10 seconds on 3D, then swapepd back to Copy in task manager and i experienced poor (very poor) Frames, i dont think DX12 iis at fault tho, because Monster hunter runs on both DX11 and 12, and both versions dont use my GPU!
 

Doutor

Honorable
Aug 18, 2015
94
3
10,645
1
reinstalled windows, my game ran for about 10 seconds on 3D, then swapepd back to Copy in task manager and i experienced poor (very poor) Frames, i dont think DX12 iis at fault tho, because Monster hunter runs on both DX11 and 12, and both versions dont use my GPU!
That's really strange than. I would advise you to start a thread about it. I wish I could help but I myself don't really know much about what to troubleshoot. It's a shame it didn't fix it for you like it fixed mine :(
 

ASK THE COMMUNITY

TRENDING THREADS