Question RTX 2080 Displayport "No Signal"

shepherdlover2

Commendable
Sep 14, 2017
8
0
1,510
0
I have the same issue alot of people in this forum has or problably is having right now, but i feel like i have exhausted all of my options from all the fixes i read..

Monitor: LG32GK950-F
GPU:ASUS ROG STRIX RTX 2080
Motherboard: Asus Rog Rampage VI Extreme
CPU: I9 9900K
RAM: Corsair Vengence 32GB

Like other people's issue HDMI works flawlessly but Displayport is a "no signal"

I have done a complete power cycle 3 times with the monitor, displayport and PC unplugged for up to 30 mins with everything unplugged.

Probably Need to update LG Monitor Firmware

Tried 3 Different Displayport cables both ways with the 2 displayports on the GPU 4.The Monitor will tell me that the displayport is plugged in and ask if i want to switch to that imput but when chosen still show a no signal.

Freesync is shut off

Power management is at High

Monitor gives option for which Displayport Version im using and have chosen 1.4,1.2,1.1 for all three displayports i own.

Rolled Back Driver to 432.00 9.No adapters are used.

V-Bios is up to date

Mobo Bios is up to date.

Bios option set to IGPU Mulit Monitor>Enabled

Disabled VT-D
 

boju

Champion
Check Displayport is properly plugged and locked in at each end. You've probably tried only with the Displayport cable connected but if not, remove HDMI cable from both gpu and monitor.

There's nothing really special required for Displayport so id suspect the card is faulty.
 

ASK THE COMMUNITY

TRENDING THREADS