Question RTX 2080 low fps, prior spontaneous 980ti catastrophic failure

Jun 13, 2020
1
0
10
0
Let me know if I should post in a different thread.

Specs:
RTX 2080 Gigabyte
i7 6700 3.4GHz
2 x 8GB DDR3L Kingston 1600MHz
850 EVO 250GB SSD (Windows 7 OS drive)
500GB SSD (Games drive)
2TB HDD (Storage)
ASRock Z170 Pro 4-D3 LGA1151 DDR3 ATX Mobo
Noctua NH-U12S CPU Cooler
Thermaltake 750W 80Plus Gold

BenQ XL2420G (Monitor)
Geforce Game Ready Driver 446.14

Issue:
Since building this rig 5 years ago I have suffered with flickering in games (Battlefield 4, Rust, Call of Duty Modern Warfare, League of Legends), micro stuttering, blue screens, freezing and continuous robotic sound requiring hard reset, mouse and/or keyboard not being powered on boot, fluctuating boot times, Windows 7 loading screen having no audio before login and crashing on startup to name a few. My original GPU a GTX 980ti spontaneously failed one day and it's failure mode could not be identified by a computer technician. The most recent issue is blue screening playing Rust (a CPU and RAM intensive game) and suffering from low FPS (20 to 50) no matter what graphics settings are used or whether or not G Sync is enabled. Also of note flickering persists even at high FPS with G Sync enabled but not when it is disabled. By flicker I mean the screen going to white between scans an issue that has been investigated by Blur Busters which I could not resolve on my computer with their guides.

Things I've tried:
DDU clean installations of all graphical drivers
New GPU (RTX 2080).
RAM diagnostic (RAM is fine)

Before addressing any of the aforementioned issues, would anyone with technical experience suggest a troubleshooting guide that I can follow to provide better information for this thread to make it easier to identify faults or anything of note for any technical experts willing to help.

Thank you in advance for your help,

ReticentRex.
 
Last edited by a moderator:

PCMDDOCTORS

Reputable
Aug 31, 2015
157
12
4,715
7
I would try the new GPU in a newer system. See how it runs and if it does fine then the problem could be that the PCI x16 slot is faulty. Have you tried a BIOS update? Maybe the version is too old to handle a RTX Card. Try a Stress Test with the GPU in different system and old.
 

ASK THE COMMUNITY

TRENDING THREADS